Why am I receiving a link error for abandoned cart?

  • 8 December 2020
  • 1 reply

Badge +2
  • Contributor I
  • 0 replies

Dear sir/madam,

So far ive had one issue with Klaviyo, that i dont know how to resolve. Despite this issue I am very happy with my Klaviyo experience.

The issue i have is that my first abandoned cart mail has a link that doesnt work. It is the link to the product that has been put in the cart of a costumer. Ive tried to put different links in to fix the problem but it keeps going to the wrong page. When i see what link it sends me to, I see that there is no ‘/’ inbetween ‘.com’ and ‘products’. But even when I put a ‘/’ inbetween these in the link, it still doesnt work… 

These are the different links ive tried to put in: 

{{ organization.url }}cart?wck_rebuild_cart={{ event.extra.CartRebuildKey }}
​​​​​​{{ organization.url }}/cart?wck_rebuild_cart={{ event.extra.CartRebuildKey }}
{{ organization.url }}/products/{{ item.product.handle }}          - (this one works with my other abandoned cart emails)

Ive also tried putting my sites url, then ‘/products’ then ‘/{{ item.product.handle }}’

In each case it sent me to:


As you see there is a ‘/’ missing… 
I have tries everything, but nothing works…

what should I do?

Info that you might need whilst helping me:
My sites URL:


Kian Boschman




Best answer by k.mcevoy 9 December 2020, 18:30

View original

1 reply

Userlevel 4
Badge +6

Hi Kian, 


Thanks for visiting the Community!


Looking at the source code of your dynamic product block , it looks like you were omitting a “/” before products in your URL. So previously it was “<a href="{{ organization.url }}products/{{ item.product.handle }}">” and I added “<a href="{{ organization.url }}/products/{{ item.product.handle }}">”. 


It seems to now be redirecting properly for me. In the future examining the source code of a text block is always your best bet for those sort of code edits!