WooCommerce integration done, but error message given

  • 14 December 2021
  • 4 replies

Badge +2

Hi everyone. I’ve just signed up to Klaviyo (as in, as a paid subscriber) and I have successfully gone through the WooCommerce integration with my site. I have installed the Klaviyo plugin on me site too, and all is working well. Klaviyo can see all of my customer history and shows me accurate stats.

Here’s the problem now…

When I go to add a new flow, I get this error message: “To get started, enable your WooCommerce integration here.”

If I click on the link it takes me to the page where I have already successfully entered the details and where Klaviyo shows me the successful integration.

Any ideas what I should be doing differently?


Best answer by stephen.trumble 15 December 2021, 01:14

View original

4 replies

Userlevel 7
Badge +60

Hey @CtrAttack_Colin 

Thank you so much for reaching out to the Klaviyo Community for help with your WooCommerce integration!

When you are on your website, right click on the homepage and then click inspect. Next click command + F and type in company_id. This should bring up your klaviyo account ID if everything was installed properly. If there isn't one in the code then the code snippet would need to be changed/updated, if there is more than 1 Klaviyo ID then you would need to remove the extra code that could prevent the integration from working. Please search for the Klaviyo.js file in your source code and then we can go from there as to how to best solve this issue for you!

Badge +3


im facing the same issue when im trying to create a new flow after adding the woocommerce integration.


  1. New Flow (Product Review / Cross-Sell)

“To get started, enable your WooCommerce integration”


  • Woocommerce integration is all setup (no errors)
  • I can see 1 company_id on my website

Do i need to wait until the historical data is synced or should it work rightaway?





Userlevel 7
Badge +60

Hey @lumotion 

Thank you so much for following up about your integration! I would try clearing your browser's cache and history, and then restart your browser if you haven't already tried. Also it could have been that the integration wasn't completed at that time because of the historic sync but that usually isn't a barrier. If it were the sync, it should be complete by now. Have to tried to build the flow again today?

Badge +3


i waited a bit longer and after the sync everything worked.