Solved

Issues with the browse abandonment flow

  • 19 July 2021
  • 1 reply
  • 177 views

Badge

Hi, I'm having issues with the browse abandonment flow, I believe the trigger is not working and I don't know why, can you help me out with this?

icon

Best answer by Dov 20 July 2021, 15:50

View original

1 reply

Userlevel 6
Badge +5

Hi @Maria Moreno,

Thank you for sharing this information with the Klaviyo Community.

I recommend reviewing the best answer to the post below which provides some steps to investigate the Viewed Product event trigger which triggers the browse abandonment flow:

In short, In order for the Viewed Product snippet to work correctly, it needs be added to your product.liquid file. If you are using custom product pages, you may need to add this snippet to those files. Additionally, in order to log the Viewed Product, event in Klaviyo, you must first be cookied on the browser and then view the product. Your browser cookie can be logged through a few different ways. This includes filling out a Klaviyo sign-up form, clicking through a Klaviyo email or self-identifying in the browser using a UTM parameter. For more details on the latter method please see the article above.

In addition to this, I recommend reviewing any existing flow filters or trigger filters on the flow, that may be precluding profiles from entering the flow. You can preview a flow trigger to see if user would qualify by using a flow trigger preview tool -- more details on that here. Also, ensure that the emails in the flow are set to live mode and that you are in fact logging Viewed Product events in the account. You can verify if Viewed Product events are being logged by navigating to Analytics > Metrics > Viewed Product. I also recommend reviewing the post below outlining general steps for troubleshooting a flow that is not firing as expected:

Thanks and enjoy the rest of your day.

Reply