Solved

Launching flows with pre-populated lists

  • 26 June 2021
  • 2 replies
  • 31 views

Badge

We’ve imported a list of subs and built a flow to nurture / educate on a new service.  

 

The Flow Filter is: “is in” the relevant list.  In the Manage Flow drop-down, I went to “Back-populate flow recipients” and selected the 2nd option: “Schedule for each step relative to when I click the back-populate button”.

 

I’ve deployed the flow.  I expected that Email #1 would go immediately *to the entire list*.  That doesn’t seem to be the case.  

icon

Best answer by david.to 27 June 2021, 14:50

View original

2 replies

Badge

Thank you, David.  That did help.  Ultimately, it was a matter of cloning and changing the flow trigger.

Userlevel 6
Badge +4

Hello @Phil-P,

Thanks for sharing your question with the Klaviyo Community!

When you say you have a flow filter that reads “is in” the relevant list, did you happen to mean that you have a flow trigger that is set set for list while having the relevant list selected?

From the details, it does sound like you are initiating the back-populate function correctly. Some common reason why the back-populate function may not be queuing users are:

  • You back-populated the flow when it was Draft mode as opposed to Live
  • Flow filters are preventing users from being queued up for the flow
  • Users are being queued up but are being skipped due to Smart Sending

If you happened to back-populate the flow when the flow was not set Live, this would mean the back-populate did occur for the flow. However, since the flow is not Live all relevant contacts would have entered the flow when it was in Draft mode and this not receive any emails. Because these contacts technically already went though this flow when it was in Draft due to the back-populate, I would suggest cloning the flow, setting all emails to Live, and then initiate a back-populate for this newly cloned flow. 

I would also recommend reviewing to see if you happened to have any conflicting flow filters in place and/or if you happened to have smart sending enabled in your emails. If you had conflicting flow filters in place, this may be preventing contacts from being queued up for the flow when it was back-populated. Similarly, if smart sending was enabled in your flow emails, this setting must also be adhered to even when back-populating. 

Lastly, I would also recommend being patient with the back-populate function. After initiating it, it may take some time for Klaviyo to calculate the number of profiles to place into the flow. I’ve personally have seen this process take upwards of 15 minutes before seeing contacts being queued up in the flow due to how many conditions you may have in the flow, how large the recipient list may be, etc. 

I hope this helps!

David

Reply