Solved

Why are my browse abandonment not sending

  • 20 May 2022
  • 6 replies
  • 90 views

Badge

I am new to Klaviyo and have set up a browse abandonment and cart abandonment work flows but not the welcome series as we are still preparing to migrate from another system.

The problem is our browse abandonment does not send to anyone and we have 30,000 visitors per month to our site.

We only have 1 product with 2 models one model for the US and the other model for Australia.

The browse abandonment flow only has one email that should send after 2 hours. and the abandoned cart has 2 emails one after 4 hours and the next after 20 hours

Below are the details. 

Browse Abandonment  - 1 email only after 2 hours. Last 30 days stats

Triggers - After someone Viewed Product. Only include someone if has Checkout Started zero times since starting this flow and has 

Stats - Waiting = 0 reviewed= 0 delivered = 0 Skipped= 0

 

Abandoned Cart - 2 emails only  | email 1 after 4 hours and email 2 after 20 hours Last 30 days stats

Triggers - After someone Checkout Started. Only include someone if has Placed Order zero times since starting this flow.

Stats email 1 - Waiting = 7 reviewed= 0 delivered = 92 Skipped =159

Stats email 2 - Waiting = 32 reviewed= 0 delivered = 73 Skipped= 158

 

Any advice on what to change and how?

 

Thanks heaps, Wade

icon

Best answer by retention 20 May 2022, 17:56

View original

6 replies

Userlevel 6
Badge +30

@Wade B. 

the most common problem that I see new people make in this kind of situations is they haven’t installed the product tracking code properly. So even though your flow looks fine, I would look into your metric and not the flow.
So you should check and see if viewed product metric is recording any data, I suspect it isn’t so you will have to fix that metric before your flow can work.

Here you have info about it and how to install it related to what kind of store you have https://help.klaviyo.com/hc/en-us/articles/115005076767-Guide-to-Klaviyo-Onsite-Tracking#viewed-product-tracking3

Userlevel 7
Badge +49

Hi @Wade B. , I agree with @Bobi N. in that you should verify that Viewed Product ias actually being passed to Klaviyo.  

A quick way to know is to go to your Sidebar → Analytics → Metrics, find the “Viewed Product” metric and check to see if you have any activity for that metric.  If you don’t see any activity there, then “Viewed Product” may not have been properly implemented and you can follow the guide that @Bobi N. referenced.  If you have already done that, here’s a good guide on troubleshooting:

Let us know how if you got it fixed!

Badge

Thanks,  I will check this out and let you know if that sorts it out.

Badge

Hi Bobi/Joseph, 

I have checked your suggestions and also the troubleshooting guide and it seems like everything is set up correctly.

Perhaps its the browse abandonment trigger flow filter set up which is is set to

  1. Check out started = Zero times 
  2. Placed order = Zero times
  3. Skip anyone that has been in the flow for 30 days

Thanks,  Wade

Userlevel 6
Badge +52

Hey @Wade B. 

One more thing to add to what  @Bobi N. and @retention mentioned already, the viewed product metric is only attributed to known browsers on your site. So although you may have 30,000+ visitors, only those who have a known browser (ie profile) will have the products they viewed tracked. So my next question is how are profiles being added to your Klaviyo account currently? If we don’t have a profile for the customer, there is no email address to put through your flows. 

Badge

Thanks, everyone. It just we have no signup forms live at the moment everything is now correct so when send the welcome series live and start capturing info the flow will begin. Thanks, heaps!

Reply