Solved

Error when importing a template: "We couldn't find the following images"


Badge

Hello guys,

 

When I'm trying to import my custom HTML template, it keeps saying:

We couldn't find the following images: "", "", "", "", "". Make sure they are included in the zip file you uploaded.

 

The images in the template are hosted on my own webserver. I also tried stripping the URLS to just ‘test-image.jpg’ f.e. and include them in a zip, but then I get a message that ‘test-image.jpg is missing’… Can someone help me out?

 

Thanks in advance!

icon

Best answer by david.to 8 May 2021, 14:38

Hello @gpnl,

Thanks for sharing this with the Community!

The import error you are seeing can typically occur from several reasons. I would recommend double checking the following:

  • Check that the files names that are being called in the HTML file matches what is given in the Image zip folder.
  • Ensure that you are not importing fonts files in the zip folder that accompanies the HTML file, only images or CSS files.
  • Confirming that the image file you upload exists alongside with the HTML template you import.

For further assistance in custom HTML templates, we would also recommend leveraging Klaviyo’s extensive network of agency partners.

Hope this helps!

-David

View original

3 replies

Userlevel 5
Badge +3

Hello @gpnl,

Thanks for sharing this with the Community!

The import error you are seeing can typically occur from several reasons. I would recommend double checking the following:

  • Check that the files names that are being called in the HTML file matches what is given in the Image zip folder.
  • Ensure that you are not importing fonts files in the zip folder that accompanies the HTML file, only images or CSS files.
  • Confirming that the image file you upload exists alongside with the HTML template you import.

For further assistance in custom HTML templates, we would also recommend leveraging Klaviyo’s extensive network of agency partners.

Hope this helps!

-David

I have the same problem but even simpler…

I downloaded the template from Envato.

I have the HTML file, I have all the image files, nice and zipped.

But still I get the error to make sure the files are in the zipped file.

 

It’s getting very frustrating.

Userlevel 5
Badge +4

Hi all,

Thank you @david.to for your reply and @Alex73 for your feedback.

Please make sure that any elements in the template you're importing don't have empty background attributes. Here's an example of what that might look like:


?name=inline-174795551.png

Thanks and have a wonderful weekend.

Reply