Solved

Flow not sending trigger email for pop-up sign up

  • 16 March 2021
  • 2 replies
  • 263 views

Badge +1

Hey everyone,

I’ve set up a flow, with a trigger to send a 10% off code email when people sign up through the pop-up on my shop. I’ve tried everything, but the email is not sending. My store is currently password-protected, as I haven’t launched it yet. Wondering if that has anything to do with it? My pop-up adds emails to the “All Shopify Signups” list (using this list as a tester so I can get the hang of this, as I’m new to Klaviyo), however, the 10% off email will not send. Really hopeful someone can help me out, as I know this is probably so simple to fix.

 

icon

Best answer by Dov 6 April 2021, 18:38

View original

2 replies

Userlevel 6
Badge +33

@jlpalumbo 

Where are you showing this pop-up if your website is passwords protected?

Is anyone subscribed to this pop-up yet? 

For this to work people have to subscribe to this list so you need to make sure people are subscribing to the list. 

Userlevel 7
Badge +61

Hi @jlpalumbo,

Thank you for sharing this question and thank you @Bobi N. for your contribution.

Having a password-protected store will not interfere with the ability to add a user to a list via a sign-up form. 

It’s a great sign that your email address is appearing on the correct list. 

With that said, there could be a couple of other interferences here.

First, the flow email status should have been “live” when the email was due to send in order for this email to automatically be dispatched. If it was in “manual” mode, the user would be in Needs Review status. And would require you to manually dispatch that email to the user. If the email was in “draft” mode, it would have skipped the user altogether.

From your screenshot I can see that smart sending is enabled and this could very well be the issue here. By default, if a profile has received any other emails in the last 16 hours, it will be skipped from an email with smart sending enabled. To verify if your profile was skipped due to smart sending, I recommend clicking into the flow analytics. This can be achieved by clicking on the flow email itself and then clicking View All Analytics on the left-hand side.

 

 

Next, click on Recipient Activity > Skipped. You will see all skip reasons here, including if it was due to smart sending being enabled on the flow email. If this is the case you can disable smart sending for this flow email to prevent future skips for this reason. There may be other skip reasons here that prevented your email from getting this flow email, I recommend having a look at those here.

Thanks, and have a wonderful day.

Reply