Solved

Order ID not showing on shipping confirmation email

  • 16 January 2021
  • 3 replies
  • 43 views

Badge

I’m using Klaviyo’s prebuilt shipping confirmation flow for my bigcommerce orders and everything seems to be working except the Order# is not filling in on the email. Here’s a photo showing the setup on the template and the email. What’s the solution for this? Thanks!

 

 

icon

Best answer by Paul S 20 January 2021, 21:53

Hi @WonderWho,

If you take a look at the pre-built flow for Order Confirmation and the template associated you’ll see {{ event.extra.id }} is what is used for BigCommerce. I would recommend trying that out in place of ((event.extra.OrderID}} and see if that ends up rendering correctly or trying to us the flow taken from the flow library to see if that pulls in properly without making any changes to the template.

 

Please let us know if either of those options ends up pulling the information you’re looking for.  

View original

3 replies

Userlevel 4
Badge +3

Hi @WonderWho,

If you take a look at the pre-built flow for Order Confirmation and the template associated you’ll see {{ event.extra.id }} is what is used for BigCommerce. I would recommend trying that out in place of ((event.extra.OrderID}} and see if that ends up rendering correctly or trying to us the flow taken from the flow library to see if that pulls in properly without making any changes to the template.

 

Please let us know if either of those options ends up pulling the information you’re looking for.  

Userlevel 4
Badge +1

@WonderWho whenever you need to add variables also have a look at the event data when you click the preview button. You can go through all the data that's available for the specific event your creating the flow for and clicking on any of those will bring up the correct variable.

more info here: https://help.klaviyo.com/hc/en-us/articles/115005084927-Template-Tags-and-Variable-Syntax#event-variables-4

In this example it's for ImageURL but that can be any of the ones listed.

 

Badge

Thanks, Paul! That was the issue!

Reply