Solved

Update property link not working in the URL field of a link (new editor)

  • 25 November 2021
  • 3 replies
  • 39 views

Badge

Trying to update a profile property using the update_property_link tag in a URL field. 

In the old editor, it works fine. In the new editor, I get an error and it mangles the formatting.

Example:

Error: 

Invalid block tag on line 8: '%20update_property_link%20'NPS%20Rating'%20'1'%20'https://baked-in-boston.com/'%20', expected 'endautoescape'. Did you forget to register or load this tag?

Thanks for your help.

{% update_property_link 'NPS Rating' '0' 'https://baked-in-boston.com/' %}
icon

Best answer by Julia.LiMarzi 26 November 2021, 17:01

View original

3 replies

Userlevel 6
Badge +5

Hi@jessebastide, thanks for reaching out to the Community today!

The syntax you have pasted looks correct. I was able to recreate your experience in the new template editor and will share your feedback with the team. 

You can still use this functionality in the new template editor. I recommend adding the tag into the source code instead of using the link option in the HTML editor.

You can use an href tag in your source code to manage preferences.

 

You can use the code below, however, update the ‘ TEXT HERE ’ with whatever text you want to show up in the template that is hyperlinked to update a profile’s property. 

<a href="{% update_property_link 'NPS Rating' '0' 'https://baked-in-boston.com/' %}">TEXT HERE</a>

I hope this helps! 

 

Badge

I’ll try that, thanks.

FYI, I tried to update_property_link in the old email editor with a new campaign (per Klaviyo docs), and I’m getting the same syntax error. Perhaps something changed / broke in the backend? 
 

Badge

More going on here.
I was able to update the link via source. Then I clicked ‘done’ to save, and sent myself a preview email. 
So far so good. 

Then, when I checked the code again, the changes I made were gone. 

 

Reply