I integrated with Facebook, so why don't I see my Facebook page on the dropdown menu?

  • 18 February 2021
  • 4 replies

Userlevel 1
Badge +4

If you integrated with Facebook, but don’t see your Facebook page on the dropdown menu for Lead Ad settings in Klaviyo, the problem might be that the Facebook user who integrated with Klaviyo doesn’t have admin permissions on the associated page. 

The Facebook user who integrates with Klaviyo must have admin permissions on the associated Facebook Page in order for Lead Ads to work correctly. The only Facebook Pages available are those where the user has admin permissions. If you don't see the page you’re looking for when integrating, then the user who integrated with Facebook doesn't have admin permissions. 

After adding a user as an admin, it’s important to remove and re-add the integration so that it will work properly. To learn how to add a user as an admin, check out this post:

Another way to solve this issue is by removing and re-adding the integration, and when you re-add, make sure to use a profile who already has admin permissions for the page. The Facebook user with the proper page permissions should follow these steps:

1. Log into your Klaviyo account
2. Navigate over to the Facebook integration page within Klaviyo.
3. Click the arrow next to Disable Integration and select Remove Integration.
4. Go to the Integrations tab. You should not see Facebook as an enabled integration since you removed it in step 3. You can now re-add the Facebook integration.
?name=inline508678235.png​5. When re-adding the integration, you will get routed to Facebook. Instead of "Continue as", you will select "Edit Settings". If you manage multiple Facebook pages, you will need to make sure this step is done.

6. The next option will show all of the pages you are associated with. From there, you select the page in question. If it does not show up at this step, make sure you are listed as an admin. 


7. Enable all permissions for the Facebook page
Once you've taken all of the steps listed above, you should see your page listed.

4 replies


Hi there,

I am having this exact issue, however, I created the Facebook page and have all the relevant admin level access but the page I need to link does not appear.

Are there any other ways to troubleshoot this?


Many thanks,


Userlevel 7
Badge +53

Hello @kmh2021,

I would double check to make sure that the Facebook page you are trying to access itself has also been granted access to your Facebook Business Account/Facebook Ad account you are working with that is connected to your Facebook login credentials. 

I hope this helps!


Badge +2

I have done all these steps as outlined and my page still won’t appear. Yes I am an admin on the page.

What is the problem?

Userlevel 7
Badge +55

Hi @jessicamdf,

Thanks for sharing this with the community.

Can you clarify if you are using Facebook's New Pages Experience?

If you are, then you will not be able to set up your Lead Ads integration at this time. Facebook has acknowledged that the 'New Pages Experience' limitation is an issue that they are investigating on their end. During this time, a workaround is to switch back to the 'Classic' view, set up the integration with Klaviyo, and then you can switch back to the 'New Page Experience' view once the integration with your lead ads has been set up. Please switch to the 'Classic' view then remove the integration and follow the steps from my pervious email to add it back

I hope that’s helpful.