Solved

Integration Issue

  • 31 January 2021
  • 2 replies
  • 218 views

Badge +2
  • New Member
  • 3 replies

Hi Community,

 

Having problem with the Integration, Klaviyo <> Shopify.

 

Chose [Automatically add Klaviyo onsite javascript (recommended)] and pasted the snippet (product) to product.liquid.

However, at this stage the profiles didn’t get updated.

 

Later, copied snippet of Theme to theme.liquid, manually.

 

After this step, the profiles started to get updated from this particular date. However, it started to pull the LIVE and current dated data and not the history data.

 

Secondly, the order related details and the history data is not being synced.

 

Could anyone help me on this, please.

 

Many thanks,

Seb

 

 

icon

Best answer by Paul S 2 February 2021, 00:24

View original

2 replies

Userlevel 5
Badge +9

Hi @Seb,

Providing what I hope will help below.

Chose [Automatically add Klaviyo onsite javascript (recommended)] and pasted the snippet (product) to product.liquid.

However, at this stage the profiles didn’t get updated.

If you’re referring to customers not getting added to your list, can you make sure you’ve followed the steps below?

Navigate to your Shopify integration page by checking the box to Collect email subscribers, and selecting a list from the dropdown. After you select the list you want to sync, click Update Shopify settings.

collectemail.png

When you integrate your Klaviyo account with Shopify, one of the properties synced from your store is whether each customer accepts email marketing or not. The property can be either true or false. Below is an example of how the property appears on a customer's profile in your Klaviyo account.

acceptmarketingUpdate.png

Secondly, the order related details and the history data is not being synced.

Have you looked at the metrics section to verify your data?

 

Klaviyo imports all of your Shopify data. Click on the Metrics tab, find the Placed Order metric, and click on it. This will take you to the metric's reporting page and show the last 30 days of data by default. I would recommend that you change the dates back to a point where you feel like you are missing data and see if there truly is data missing where the number of events is zero until it starts getting tracked. 

mceclip2.png

 If you’re finding an issue where there truly is an issue with the historical sync, feel free to follow up. 

Badge +2

Thank you @Paul S for your response.

 

Got in touch with Alex(support team). Got this resolved.

 

Many thanks again Paul

Seb

 

Reply