Solved

Can't import reviews to Klaviyo as a CSV file, Can't process at all. Unknown Error.

  • 21 February 2024
  • 4 replies
  • 88 views

Badge

Hi, I need urgent help on this, I have tried several different ways to line up the columns: I did as advised here. It didn’t work & also I kept receiving Unknown Errors.

Here is how I lined the columns in different ways, nothing worked:
I chose Shopify as the reviews provider every time.

1.


2.

3.


Here is the Error I keep on receiving:
 

​​​​​

FYI: These are the translations of our german customers’ reviews.

icon

Best answer by Julie07 23 February 2024, 15:33

View original

4 replies

Badge +3

I’m having the same error, checked everything with the help page, but  the troubleshooting in the article is not enough, nothing works.

Badge

also it looks like nobody helps

Userlevel 7
Badge +59

@havvameletli - I’m not super familiar with the Reviews import process, but taking a quick look, I noticed your Product ID values are wrapped in quotes “”.  Have you tried removing the quotes and see if it works?

Also, when I have CSV import issues in general (not just reviews), sometimes a misaligned comma, or a special character or in your case extra Quotes could break the process.  What I do is try to use a smaller set of data, make sure its super clean and well formatted, and then if that works, try a bigger set of data until you can find which row or data is breaking the process.

Sorry we can’t be more helpful here, but perhaps others have other insights they can share.  Also, have you tried reaching out to Klaviyo support?  Perhaps they can help you directly in this case.

Userlevel 5
Badge +18

@havvameletli Hey there, thanks for reaching out to the community!

Seems like in your first screenshot, second column, there’s a typo where an extra ‘ sign is displayed next to the “Reviewer Email” column title. Try removing that, then reuploading the first dataset.

For the second screenshot, I agree with @retention, try removing the quotes around the product ID column.

The third screenshot doesn’t have anything wrong with it upon inspection, but the data are jumbled together so it’s very easy to miss a detail.

Ultimately this might be the case of a typo or data value entered incorrectly, which throws the platform off.

Please let us know after troubleshooting if this solved the problem. Note that the column names need to match your profile properties EXACTLY (incl. spelling and capitalization) for the CSV import to be successful - this is a common issue.

Happy to chat further!

 

Reply