Can't Integrate Typeform

  • 4 September 2021
  • 9 replies

Badge +2

I am trying to connect my typeform quiz to klaviyo. I click integrate, then select “Advanced Options” then “only sync specific forms” i copy and past the form id as show in the how to guide. “OvXTX6fP” and select “connect to typeform”. It brings me to the page ive screen shot below. 

Ive tried checking typeform status but everything is good. Can anyone tell me what I am doing wrong? 


Best answer by tiebar 7 September 2021, 20:59

View original

9 replies

Anyone has an update on this

Badge +1

I am having exactly the same problem, already wrote an email to the support team. No answer so far. Even starting the live chat with customer support doesn’t work. Don’t know what is going there...

Badge +1

Facing the same issue. When reached out to Typeform, they directed me to reach out to Klaviyo team as this integration is managed by Klaviyo.

Userlevel 7
Badge +60

Hey @Derick_nyc !

Thank you for reaching out about this! 

Your screenshot is from Typeform's hand and 500 is a server issue. A 500 error indicates that there’s an issue with Typeform. Although Typeforms status page does not reflect an issue, their engineers are currently working on this bug. When it's resolved you might need to re-integrate with Typeform on Klaviyo, by following this guide

I hope this helps, and any updates we get will be posted in this thread. Thank you all for being members of the Klaviyo Community!


Badge +2

@stephen.trumble so youre saying its a typeform problem not a klaviyo problem. is that right?

Badge +1

While I’m waiting on a response from Typeform Support team, reached out to Klaviyo Support for the same. During the process, Support Personnel asked me to use InCognito mode and it worked with out any authentication issues.  Typeform and Klaviyo are connected now for me. So, hoping this should get everyone temporarily up and running using private mode while the team is working on a permanent fix.

Userlevel 7
Badge +60


After some further investigation, @tiebar suggestion has worked for some users by using an incognito window. Also, one user signed out of their Typeform account completely, removed the integration and set it up again so they were required to input their Typeform credentials again, and that seemed to work for them as well. 

I will continue to update this thread with information as it comes to me! Thank you all for your patience will we find a solution for everyone!

Badge +2

@tiebar , thank you for the incognito tip. This worked for me. I talked to Typeform about this issue, and they told me that its a known bug, and they are trying to fix the issue but they are having issues because the connections is built from Klaviyo. He didnt have an eta on a fix.

Userlevel 7
Badge +38

@tiebar would love to see a case study on how you’re using the Typeform integration with Klaviyo. 


We just started using it and did a campaign a few weeks ago to collection submissions for a member of the month.  The answers from the questions we asked in the Typeform then helped us in determine segments (ie. product type, favourite teams, etc..)