Solved

Our API integrated metrics are not working...

  • 15 February 2024
  • 3 replies
  • 25 views

Userlevel 2
Badge +5

If you look at our API metrics like Checkout started, Active on site and Placed order for the past 15 days, you can see that they have not been working properly. Even though people are active on site, people are checking out and placing orders.

Due to this, flows are not getting triggered, meaning no emails are getting sent.

Can someone advise on this, please?


 

 

icon

Best answer by Casperackermann 22 March 2024, 15:25

View original

3 replies

Userlevel 2
Badge +5

@stephen.trumble - Hi Stephen, any idea why this is happening?

Userlevel 7
Badge +36

Hi @nambirajanks!

 

My apologies for the delay here. Is this still occurring?

Best,

Brian

Userlevel 1
Badge +1

As it’s both client-side and server-side events it makes it a bit more troublesome. Is it a custom integration you have setup? If so, I’d start looking into if any changes have been made to the javascript that’s implemented (client-side) and then move on to verify that the API integration (server-side) are correctly set up and are functioning as intended. Make sure to ensure that the endpoints are correct, authentication is valid, and that there are no changes in the API that might have affected the integration.

Consider if there have been any recent changes in your system or in the APIs that could have led to this issue. Sometimes, updates or modifications in one part of the system can affect other areas.

I, however, find it strange that both javascript events and server-side should stop working at the same time..

Reply