Custom profile lookup is showing up as "none"?

  • 5 March 2022
  • 2 replies

Userlevel 1
Badge +2

Hi! I am crafting an email to our customers that requires each customer to get a “reactivate” account URL that is unique to their email/account.

My plan is to create a list where I upload a .csv that has each customers unique link is uploaded using a custom profile property of “reactivate_url”. I’ve tested this on 2 accounts and I see that it has worked -- both have the profile property “reactivate_url” in their account, and the URL is shown after that. 

However, I’m trying to craft an email that pulls this URL into the email, so customers click the link and are taken to their unique reactivate account page. 

I’m using the code:

{{ person|lookup:'reactivate_url'|default:'' }} I pulled it using the “Insert Property” tool (screenshot below).

However, every time I try and test this, it does not work. Any ideas on what I’m doing wrong? We use this method in another email template with a different URL that is unique to customers, and it works just fine, so I’m really not sure what the difference is here.

Any insight would be helpful!



Best answer by aereid 5 March 2022, 01:51

View original

2 replies

Userlevel 1
Badge +2

Found my own answer, but posting in case anyone else needs it! Because I filtered that LIST into a SEGMENT (to function as the metric for a triggered flow), I needed to actually push the Flow live for the first time for it to start registering the metric. Once I pushed it live with my “test” accounts, it worked as it should. 

Userlevel 7
Badge +60

Hi @aereid


Thanks for sharing out your workflow of how you solved this problem! I know it will definitely benefit other users in the future who might have a similar situation!


Thanks for your participation in the Community!