Solved

Flow not sending to all subscribers in the Segment used as trigger

  • 16 August 2021
  • 3 replies
  • 60 views

Badge

Hi! 

 

I created a Newsletter flow and used a Segment I created as its trigger. I have over 5,000 subscribers from my mailing list on this Segment. The number also keeps on growing as some more conditions are met from people who are on our Shopify.

 

 

However, of the 5,000 emails included on the Segment, only about 100 emails were delivered when I tested the first email on the flow. I was wondering why would that be? 

 

 

Would appreciate your suggestions and help as I am getting quite frustrated :sweat_smile:  Thank you!

icon

Best answer by Bobi N. 16 August 2021, 09:58

View original

3 replies

Userlevel 5
Badge +3

@mermaidzeli 

When flow is triggered by segment (or a list) people who are already in that segment (or list) when flow is created are not triggering the flow. As you can see in the trigger name trigger is when someone JOINS list or segment not when they are in it.

So your problem here is that those 5000 people were already in segment when you started the flow so only new people who join the segment will trigger this flow.

There are 2 ways that I can think of that you can fix this.. 

1st is if you don’t have dynamic coupon codes or dynamic product blocks in this flow, you can backdate the flow and all the people in that segment can go through the flow.

2nd is create new flow started with new empty list (make sure to set single opt in when creating this list), and than when that flow is ready and set live (but remember it must be live first) download the people from this segment and upload to that new list. So when you add people to that new list this new flow started with that new list will trigger for all of the people added there..

Userlevel 6
Badge +5

Hi @mermaidzeli,

Thank you for sharing this post with the Community! And thank you @Bobi N. for your helpful reply.

@mermaidzeli, Bobi is spot on with his suggestions! On the first point, with respect to backpopulation, ensure you use the bottom radio button when backpopulating: “schedule recipients relative to when I click the backpopulate button”. This option treats recipients as if they just joined your list or segment. They’ll start at the very beginning of the flow and move through it one step at a time, like any other recipient. Also, users that already received the first email in the flow will not receive the email again when you backpopulate.

Thanks for being a member of our Community.

Badge

Thank you so much for all your suggestions! It worked perfectly. I appreciate this community :)

Reply