Solved

Mismatched data while importing CSV file

  • 22 June 2021
  • 4 replies
  • 45 views

Badge

Hi there,

I’m trying to import a CSV file and when I do, I get mismatched data all over. So I have gone and review the data type, and tried a different one with no avail. I won’t import and it doesn’t matter the data type I choose.

 

Anyone has an answer to fix this?

 

Thank you,

 

Francisnelli

icon

Best answer by elisegaines 22 June 2021, 20:59

Hey Francisnelli! 

 

I’m so sorry to hear you’re having trouble importing. When this happens, it’s almost always because of a “data type” that doesn’t match the data in your file. Here are some common areas where I’ve seen this happen: 

Dates: our upload tool can only accept certain date formats. Check out this guide and make sure all dates are in an accepted format. 

Consent: The consent data type requires a very specific “array” format, and can only hold certain values as well, like this: ["sms","push","directmail"] 
If you have a “consent” field and it uses true/false values, select “Boolean” as the data type instead. 

 

We have a guide with a lot more detail about troubleshooting list uploads as well.

 

I hope this is helpful! If you’re still having trouble, feel free to share more detail here and we can take a look (for example, a list of the columns in your spreadsheet and the type of data in each). 

 

Best,

Elise

View original

4 replies

Userlevel 5
Badge +4

Hey Francisnelli! 

 

I’m so sorry to hear you’re having trouble importing. When this happens, it’s almost always because of a “data type” that doesn’t match the data in your file. Here are some common areas where I’ve seen this happen: 

Dates: our upload tool can only accept certain date formats. Check out this guide and make sure all dates are in an accepted format. 

Consent: The consent data type requires a very specific “array” format, and can only hold certain values as well, like this: ["sms","push","directmail"] 
If you have a “consent” field and it uses true/false values, select “Boolean” as the data type instead. 

 

We have a guide with a lot more detail about troubleshooting list uploads as well.

 

I hope this is helpful! If you’re still having trouble, feel free to share more detail here and we can take a look (for example, a list of the columns in your spreadsheet and the type of data in each). 

 

Best,

Elise

Badge

Hi Elise,

Most of the fields have no data yet (I just joined Klayvio) and because I am not sure what type of data they are, I’m leaving as string since that’s what it is recommended by Klayvio “how to”

 

My date is MM/DD since I don’t want to collect YY. Do you think that it is a problem?

 

Thank you

Userlevel 5
Badge +4

Great question - I do think that might be the issue. You can either try importing the date as a string, or (and this is what I’d recommend), add a fake year to all of the date values.

 

Let me know how that goes! 

Badge

I’d found what was causing the problem… in the consent field, the “email” property was all weird like “[“”email””]” something like that. The two contact that didn’t have that, worked when I imported as string. I went back and deleted all that weird property and imported again. Voila! It imported all… including the custom property “real birthday” without the year.

So hopefully now I can create the flow I wanted for “Real Birthday”

Thank you so much, Elise

Reply