Solved

Missing custom properties when creating segments

  • 6 November 2020
  • 2 replies
  • 166 views

Userlevel 1
Badge

Has anyone else noticed any of their custom properties missing when trying to use them within segments?

I’ve created some custom properties for when subscribers have completed a flow. but when attempting to use that custom property to create a segment, it doesn’t show up in the drop down list of properties to choose from? It’s hit and miss - some show up, some don’t, even though they have been created in exactly the same way.

Appreciate if anyone has any advice on a fix?

Thanks,

Meeta

 

icon

Best answer by cassy.lee 10 November 2020, 01:26

Hi Meeta @meets 

If you have created some custom properties for users to pass through a flow, the custom properties first has to exist on a customer profile before they'll appear in the segment drop-down option. So if zero profiles have gone through that step in the flow, the property won't show in the segment builder. If you want to test a customer property, I would recommend pushing a profile through the flow and manually add the property to a profile in the account (via CSV file upload or by manually adding on the profile page). You can learn more about custom properties and how to manually add them to a profile with this guide.

Thanks, 
-Cassy

View original

2 replies

Userlevel 6
Badge +5

Hi Meeta @meets 

If you have created some custom properties for users to pass through a flow, the custom properties first has to exist on a customer profile before they'll appear in the segment drop-down option. So if zero profiles have gone through that step in the flow, the property won't show in the segment builder. If you want to test a customer property, I would recommend pushing a profile through the flow and manually add the property to a profile in the account (via CSV file upload or by manually adding on the profile page). You can learn more about custom properties and how to manually add them to a profile with this guide.

Thanks, 
-Cassy

Userlevel 1
Badge

Hi Cassy,

Thanks for getting back to me! Okay, I get it - so it can only be used if someone has that custom property assigned to them, that makes sense!

Thanks,

Meeta

Reply