Solved

People don't get add to my Newsletter list

  • 25 January 2021
  • 2 replies
  • 96 views

Badge

Hey,

everyone gets added to my Klaviyo Profiles List but for some reason not to my Newsletter list. I already tried to turn off the opt-in feature but it didn’t work.

 

Does my shopify store need to be public to everyone in order to work? I’m currently in the testing phase.

icon

Best answer by retention 27 January 2021, 05:07

@KapG - A few things to double check:

  • Make sure in your Shopify Integration settings, you selected the right Klaviyo List you want subscribes who “Accept Marketing” to go into.
  • Make sure the “Collect email subscribers” option in the Integration is enabled.  See here: 

     

  • In Shopify, you need to make sure your subscribers are properly tagged with “Newsletter” if you’re using a 3rd Party or custom developed theme that collects emails into Shopify.  It should look like this: 

    <input type="hidden" name="contact[tags]" value="newsletter">

     

  • Finally, make a few test orders in your test account and see if you see any events coming through to verify the Integration was properly setup.   

For further resources, you can try these resources:

Reply back if it worked or you need more help!  

View original

2 replies

Userlevel 6
Badge +5

@KapG - A few things to double check:

  • Make sure in your Shopify Integration settings, you selected the right Klaviyo List you want subscribes who “Accept Marketing” to go into.
  • Make sure the “Collect email subscribers” option in the Integration is enabled.  See here: 

     

  • In Shopify, you need to make sure your subscribers are properly tagged with “Newsletter” if you’re using a 3rd Party or custom developed theme that collects emails into Shopify.  It should look like this: 

    <input type="hidden" name="contact[tags]" value="newsletter">

     

  • Finally, make a few test orders in your test account and see if you see any events coming through to verify the Integration was properly setup.   

For further resources, you can try these resources:

Reply back if it worked or you need more help!  

Userlevel 5
Badge +4

Hi @KapG,

Thank you so much for sharing your question with the Klaviyo Community. Also, thank you @retention for your reply, this is all great information.

 

@KapG - A few things to double check:

  • Make sure in your Shopify Integration settings, you selected the right Klaviyo List you want subscribes who “Accept Marketing” to go into.
  • Make sure the “Collect email subscribers” option in the Integration is enabled.  See here: 

     

  • In Shopify, you need to make sure your subscribers are properly tagged with “Newsletter” if you’re using a 3rd Party or custom developed theme that collects emails into Shopify.  It should look like this: 

    <input type="hidden" name="contact[tags]" value="newsletter">

     

  • Finally, make a few test orders in your test account and see if you see any events coming through to verify the Integration was properly setup.   

For further resources, you can try these resources:

Reply back if it worked or you need more help!  

 

I’ll also add that changing the opt-in settings to single opt-in after someone has already subscribed, wouldn’t automatically subscribe them to the list. You would have to test a net-new profile on the sign-up form in order to submit the user to the list, or confirm your subscription for a profile that has already filled the form.

Additionally, having a non-public Shopify store will not impact the ability to submit users to a Klaviyo list, however as @retention correctly pointed out, if you are using a Shopify sign-up form, you may have to add the newsletter tag to your form. You can verify if this is correctly a part of your form by spot-checking a profile in Klaviyo and looking under the custom property Shopify Tags. If you see newsletter there it is likely a matter of confirming the subscription. I would also check your spam/junk/promotions folder for the opt-in email.

Thanks and have a great day.

Reply