Solved

Profiles Consented but not in Newsletter List

  • 18 May 2022
  • 1 reply
  • 71 views

Badge

Hi there. I’m noticing 2K+ profiles that have the consent for email box checked but they are not in my newsletter list. From what I can see, they got into Klaviyo from Shopify but I don’t see how they are consented without signing up via one of my Klaviyo forms or the checkbox at checkout (email me with offers). I have already ruled out the double opt-in and email confirmation and both of those are good to go. Does anyone know why these profiles would be consented but NOT in my newsletter list??

icon

Best answer by retention 18 May 2022, 19:53

View original

1 reply

Userlevel 7
Badge +49

@AshleyH, welcome to the community!

Assuming you’re talking about emails captured through Shopify (Checkout or Shopify Forms), if you’re not finding your Shopify consented emails, first check to see if your Shopify Integration (in Klaviyo) Subscriptions settings is enabled, and referencing the correct Klaviyo List.  See here:
 

 

Next, it’s rare but not impossible, but make sure Shopify is integrated with the correct Klaviyo Account.  Sometimes, you might have accidentally created a new Klaviyo Account while logging into Klaviyo within Shopify’s App interface which then automatically switches the integration to a brand new Klaviyo Account and not the one you expected.  You can look at the Klaviyo Shopify Integration to see some “Recent data”

If you’re not getting events that you expect here, then the Klaviyo Account might not be properly integrated.

And finally, in case you’re using a third party or custom Shopify Theme to “capture email” - you may want to verify that the Form has all the correct Form tags to pass on consent to Klaviyo:

Notably this part in the documentation:

It is also important to note that if you use a Shopify third party theme, your theme's default signup forms must also apply the Newsletter tag to new subscribers in order for Klaviyo to automatically sync these subscribers to a Klaviyo list. Contact your theme developer, or if you're comfortable editing your theme's source code, add the following hidden input tag to your form's input group: <input type="hidden" name="contact[tags]" value="newsletter">

 

Let us know if this helped!

Reply