Troubleshooting help: why won't my list import?

  • 27 November 2020
  • 5 replies
  • 997 views

Userlevel 6
Badge +21

If you’re importing a list into Klaviyo, proper formatting is very important. I wanted to share some of the most common issues with importing lists and some troubleshooting tips on how to fix them. Check that:

  • Your file is a .csv (comma-separated values) file. 
    • If you’re in Europe, your spreadsheet software may export .csv files using semi-colons “;” not commas “,”. You can change this by going to your devices regional settings > advanced settings and changed the symbol used to separate lists.
  • The first row contains column headers
  • The email column header is properly named
    • Name the column either “Email” or “Email Address”
  • You do not have duplicate headers (this includes blank headers!)
    • If you are receiving an error message about duplicate headers in your sheet and you double-checked that all your columns have unique names, delete any blank columns from your sheet and try uploading again. 
  • The file size is 50 MB or fewer
  • Every row has an email address associated with it
  • No duplicate email addresses
  • All email addresses are formatted properly (ex: klaviyo@example.com) 

For more details and troubleshooting help, check out our article on How to Troubleshoot List Imports. And if you’re still having trouble, post below and let our community help!


5 replies

Badge

Hi Julia,

I’m testing the import with only with record and the email is emilyraftery@hotmail.co.uk . I think this email complies with Klaviyo rule and certainly a valid email address. However, Klaviyo keeps denying and saying that email is invalid. Also, it says 7 records while I’m importing only one. You have any idea about how to fix this?

My record:

Klaviyo error message:

 

Userlevel 7
Badge +58

Hello @thuhuynh,

For a case like this I would first recommend double checking to see if there is any additional spaces before or after the email address in case it may have gotten copied to the file incorrectly. I would also recommend ensuring that there aren’t any latent formatting within your .CSV when importing that may be causing the import to inaccurately recognize the fields. 

You can alleviate any additional formatting by copying all your data points and pasting them into a new spreadsheet without formatting. If you’re using a PC this can be done by using Ctrl+Shift+V instead of Ctrl+V when pasting. If you’re using a Mac, you would use Option+Shift+Command+V. 

I hope this helps!

David

Badge

Hi David,

I managed to find out the reason. Not sure why my csv has unexpected “\n” characters, which made Klaviyo interpreted my one record as multiple records.

Thanks for your help.

Badge

The list import trouble shooting is something I find very confusing. I have read all the tips (space, list separator, right file format) but somehow it still doesn’t work. 

See the below screenshot for my computer/excel setting:

 

Error msg:

 

Anyone with additional tips would be very welcome. Tks in advanced. 

Userlevel 7
Badge +61

Hi @vunacoffeeschool,

Thanks for sharing this with us.

I just wanted to double-check that in addition to the strategies you’ve mentioned, you’ve run through all of the troubleshooting steps in our guide here.

If so, and you’re still having no luck, I would try changing the decimal symbol, if this represents what I think it does, then that should be a period rather than a comma.

Reply