Solved

Typeform custom properties not autopopulating when creating a segment

  • 28 April 2023
  • 3 replies
  • 64 views

Badge

My Typeform quiz is designed to identify dog personality. It includes a request for contact information (first name, last name and email) to send the personality results. I would like to create segments based on the personalities. But they are not auto populating as a ‘property about someone. Please advise. Thank you! 

icon

Best answer by David To 2 May 2023, 17:10

View original

3 replies

Userlevel 7
Badge +60

Hello @Vickey,

Welcome to the Klaviyo Community!

Looks like you’ve run into the common behavior of trying to create a segment/filter definition without having prior data. 

I would suggest taking a look at some past Community posts on this topic. I’ve included some below to get you started:

I hope this helps!

David

Badge

Thanks David. I completed the form a few times to generate the custom personalities. However, they still don’t auto-populate. None of the items in the list are associated with the typeform quiz. Any advice? 

 

Userlevel 7
Badge +60

Hey @Vickey,

If you’ve tested the form yourself and have waited an hour for the data to sync over but are still missing those properties, this leads me to believe this could be something related to either the Typeform integration or the how the form is setup. 

You can check to see if this is a Typeform integration or setup error by:

  1. Filling out the Typeform using a new email address that isn’t already in Klaviyo
  2. Waiting at least an hour for the data to sync
  3. Navigating to the profile in Klaviyo
  4. Review to see if those Typeform answers were stored properly as custom profile properties

If you notice that the new email address/profile that you used to fill out the form was not synced to Klaviyo, this could means you either do not have an email field in the form, have multiple email fields in the form, or there is an error in the integration. 

A single email field is required in order to have a profile created in Klaviyo to identify the user filling out the form. When you have multiple email fields, this could cause a disconnect and cause profiles to not be synced over.

When it comes to an integration error, the easiest way to resolve this would be by fully removing the Typeform integration and re-integrating again. I oftentimes recommend fully clearing the cookies and cache and going through the integration through an incognito browser.

If you notice that the profile is synced to Klaviyo but you don’t see those Typeform questions and answers appear as custom profile properties, this may indicate that the Typeform form itself may not be setup correctly. In my experience, this is caused by the questions not being mapped correctly. For example, if your form question contains "business", "employer", "organization", or "store", the response will be stored under the $organization property.

I hope this helps!

David

Reply