Solved

How to make sure sign-up forms are shown only once

  • 10 March 2023
  • 9 replies
  • 465 views

Badge +2

Hello,

We currently use sign-up forms (announcements/pop-ups) to inform our customers about promotions and freebies. However, we cannot seem to find how to make sure the form is only shown once. 

Although we have switched on the button "don't show again after submitting or closing..." the fly-out or pop-up keeps on popping up when visiting another page during the same session/visit.

Are we missing something?

Kind regards,
Lien - content creator for Mamzel 

icon

Best answer by Taylor Tarpley 30 March 2023, 16:44

View original

9 replies

Userlevel 6
Badge +34

Hi @Lien Mamzel ,

Welcome to the Community! Thank you for the great question about Sign-Up Forms.

In addition to enabling the “Don't show again after submit form or go to URL action” setting, you can also control the time interval between when a user would see the form again after closing it. This is set via the “Show again X days after closing” field:
 

If you currently have this set to 0 days, the Sign-Up Form will reappear for a user upon every new session. I would recommend pushing this to 30 days if you are seeing that the form is displaying too frequently for those who have not submitted it yet. 

If this option is not set to 0 for you, but you still see the pop up appear every time you open a new page, please test it in a incognito browser and clean your cookies.

In addition to this, I would recommend enabling the “Don’t show to existing Klaviyo profiles” targeting behavior so that anyone who is already subscribed to your list will not see this form on the site. 
 




There are two other great threads here on the Community that speak further on these settings:


--

Hope this helps!

-- Ashley Ismailovski

Badge +2

In fact, we did enter a number of days NOT to show the pop-up again after closing. However it kept on appearing on every page. Even when we visited the site via incognito mode.

Badge +2

Is it possible there’s a bug in Klaviyo? ‘Cus where you have to enter a number of days for the form NOT to be shown again after closing it, the question mark shows an explanation that says “how often a form will display to the same visitor”.

 

After changing this number from 15 to 1, the form now only displays one more time after being closed. 

Userlevel 5
Badge +28

Hi @Lien Mamzel 

The “how often a form will display to the same visitor” section will determine how often a form will display to the same visitor. When you have 0 days in this setting, visitors will see the form on every page load even after closing. Once you update this setting to at least 1 day, the form will only appear to each visitor once a day (or however many days you choose). For a simple list growth popup, Show again 5 days after closing is a good place to start. I hope that helps!

I can definitely share your feedback with the product team that was unclear. Thank you for sharing!

~Chloe

Badge

I’m having the same issue. My Sign Up form keeps popping up. It’s pops up every other click on the my site. 

I set it to show again after 30 days and checked the box “don’t show again after submit form or go to URL action”.

I had to set it to draft mode to stop it from constantly popping up.

Any other ideas on how to get this fixed?

 

Userlevel 7
Badge +60

Hi @ToolGuy

 

If you’re measuring this form’s activity for non cookied browsers of your site, ie they have not accepted your website’s cookies or accepted any kind of marketing from you brand, I’d check out this response in a similar thread here to understand why and find a workaround! 

 

 

-Taylor 

Badge +2

@Taylor Tarpley Now I’m even more confused.🙈

 

You say that if it is set on 1 day it will be shown once a day. That - in my opinion - is not the same as  a form that will only be shown again 1 day after closing.🤔

 

And in another comment you say this has to do with targetting the behavior and whether or not a visitor has agreed on gathering cookies. 🍪

 

One should not depend on the other when chosing how many times you wont to show a form after it is closed.

 

Why is’nt there an option to choose if you want to show it based on behavior/cookies or just based upon the fact that the form has been closed/submitted❓

 

Hope you don’t mind me asking some more input/feedback on this topic. We’re just eager to learn and profit from using the forms

 

Kind regards, Lien

Userlevel 7
Badge +60

Hi @Lien Mamzel

 

I can explain the confusion, happy to clarify further! 

 

Essentially, I shared this bit of info to explain if your form is set to display to all visitors, but keeps popping up, despite targeting rules, to your non-Klaviyo customers, and therefore non cookied users, that is the expected behavior for forms in certain parts of the world! Whether or not a user has accepted cookies and how a form will target non cookied users is related as a form will not recognize who the visitor is and therefore know how to behave if they haven’t been identified by Klaviyo.

 

You can learn more about that in this part of the targeting section of our form documentation 

 

-Taylor

Badge

I’m having the same issue. Maybe it was explained but I didn’t understand. I want the form to appear after 90 seconds and it’s set to appear only to non subscribers. But I’m not given the option to set this rule, because the option says ‘show again after’. So when I typed 90 second’s there, the form will appear every 90 seconds it seems. Or maybe it appears because I open a new page. I’m in Norway, and by law users must be given the option to opt out of coockies. 

So what you said is that because I don’t ask my customers if they accept coockies, the flyout doesn’t recognize the ip and whether it is a new customer or not, or a sunscriber or not? On every page? 

May you please give me a quick rundown as to how I can fix this (and also, when I set the rules on the flyout and choose time delay, is it supposed to say that it will be shown AGAIN after x seconds? That’s confusing to me, I just want to set the rule based off when the customer opens my page, show the flyout after 90 seconds and dont show it again before a week. I set it to 0 seconds on the screenshot, because I don’t want it to be shown again, I just want it to be shown, period. Maybe my autistic ass is reading to much into the wording and I make things harder than it is!)

 

 

Reply