Solved

[Webflow] Only one embedded form displays when there are two on a page.

  • 28 March 2023
  • 3 replies
  • 56 views

Badge

I am using Klaviyo embedded forms on a Webflow site; in the section before the footer and the subscribe button in the footer.

When there is only one instance of the form on a page, it works perfect. But when there are two instances of the form on a page, only the first instance displays while the second doesn’t display at all.

Using Chrome’s Inspect tool both forms have similar HTML including a “form-version-cid-#”. The first, displayed instance of the form has a “form-version-cid-1” while the second, non-displayed form instance has a “form-version-cid-2”. I assume this is where the issue is.

There is only one JS script in the site. If you’re familiar with Webflow, it’s in the Project Setting > Custom Code > Footer Code. I also have tried making both HTML Embeds have the same IDs and classes.

 

icon

Best answer by Taylor Tarpley 28 March 2023, 22:44

View original

3 replies

Userlevel 7
Badge +59

Hi there @Dylan P.

 

Thanks for sharing your question with us, good catch! 

 

This behavior has been identified as a bug! Our engineering team is currently investigating the issue and working to correct the issue. I will let you know when I have an update.

 

Thanks for participating in the Community!

-Taylor

Userlevel 7
Badge +59

Hi @Dylan P.

 

Happy to share that is issue has been fixed! 

 

Please let me know if you’re still experiencing issues.

 

-Taylor 

Badge

@Taylor Tarpley Works like a charm! Thank you for the answer and follow-up. Greatly appreciate it!

Reply