Solved

Klaviyo Embedded form is not showing on wordpress site

  • 20 July 2022
  • 3 replies
  • 200 views

Badge +2

Hello there,

I am using wordpress woocommerce with wp bakery page builder, installed code snippet, copied the html code of the embedded form & pasted it on site, but the form is not showing.(see attachment)

 

Also tried with wpbakery text block, the result is same(see attachment)

What is the possible solution?

 

In the klaviyo documentation & other sections, they are suggesting to use it on the footer widget. But I want to paste it on a web page

 

icon

Best answer by Taylor Tarpley 21 July 2022, 17:59

View original

3 replies

Userlevel 5
Badge +20

One hunch is that in your form settings - under targeting, do you have the settings set to not show to Klaviyo profiles?

If so, you may be cookied currently to your Klaviyo own profile and so it isn’t showing on the front-end. 

 

 

Badge +2

I’ve clicked - show to all visitors

 

Userlevel 7
Badge +55

Hi @Amir Hossain

 

Thanks for sharing your question with us! 

 

@Spark Bridge Digital LLC, thanks for helping to troubleshoot your peer’s issue. Checking the targeting behavior of the form was a great step to check in the troubleshooting process!

 

Now that we can rule that out. @Amir Hossain, do you mind sharing the form’s purpose and where you want it to display? You definitely, don’t have to have the embed form show in the footer of a web page if you don’t want to. Since you’ve integrated with Woocommerce, you don’t need to manually insert the .js code onto your site in order for this form to display. Can you confirm that you have specified which specific page you want them embed code to display on and have inserted the embed code on that page? I can’t quite tell by the screenshot you shared. 

 

Thanks for participating in the Community!

-Taylor

Reply