Solved

Not receiving preview email to my business email - issue started recently

  • 18 May 2024
  • 4 replies
  • 54 views

Badge

Hi there! We send preview emails to our email domain and so far this hasn’t been an issue, until this month. If we send it to another domain (including gmail), we receive the email, but not when it’s sent to our own domain.

(When we send out the campaign, we do receive that campaign email in our email domain).

As far as I can see DMARC etc has been set up correctly.. and hasn’t changed either. We set that up months ago and never had an issue until this month.

Is there anything we can check to see why the preview email is not coming in?

icon

Best answer by JACKSON_12 18 May 2024, 19:01

View original

4 replies

Userlevel 4
Badge +14

@HolyMoley Welcome to the Klaviyo Community!

Thank you for your question. 

Please check your spam folders to see if it has been sent there.

Have you installed any anti-virus software that might be preventing it from being delivered?

Thanks!
Alexandra 😊

Badge +1

Hmmm, this is a bit puzzling. Since you mentioned that you've already checked your DMARC settings and haven't made any changes, here are a few more suggestions to consider:

  1. Check if your email domain or server has any new spam filtering rules in place that could be affecting the preview emails.

  2. Verify that the email address you're sending previews from hasn't been blacklisted or blocked by your own domain.

  3. Confirm that the email client you're using to receive the preview emails isn't filtering them out or sending them to a junk folder.

  4. Test the preview email with different email clients or devices to rule out any client-specific issues.

If you're still experiencing issues after checking all of these, it may be worth reaching out to your email hosting provider for further assistance.

Badge

@HolyMoley Welcome to the Klaviyo Community!

Thank you for your question. 

Please check your spam folders to see if it has been sent there.

Have you installed any anti-virus software that might be preventing it from being delivered?

Thanks!
Alexandra 😊

Hi Alexandra! I checked the spam folders and it’s not there..

(plus.. when I go live with the campaign, I get the emails fine.. same email.. same email address.. no problem..)

 

Thanks!

Badge

Hmmm, this is a bit puzzling. Since you mentioned that you've already checked your DMARC settings and haven't made any changes, here are a few more suggestions to consider:

  1. Check if your email domain or server has any new spam filtering rules in place that could be affecting the preview emails.

  2. Verify that the email address you're sending previews from hasn't been blacklisted or blocked by your own domain.

  3. Confirm that the email client you're using to receive the preview emails isn't filtering them out or sending them to a junk folder.

  4. Test the preview email with different email clients or devices to rule out any client-specific issues.

If you're still experiencing issues after checking all of these, it may be worth reaching out to your email hosting provider for further assistance.

Thank you for your response!

  1. Not that I know of. And the campaign itself doesn’t have the issue, only the preview. Content wise those emails are the same…
  2. Isn’t it just 1 field that has the “from” address and that works for everything? Or is there a special set up somewhere for preview emails? (I haven’t found that if that’s the case). Again, if this is the same email.. nothing has changed in that regard and campaigns are going through fine…
  3. I can confirm. It’s not in the junk folder. This is happening on different email clients, so it’s not the ‘final’ email client we work with. If we go to the web version, we have the same issue there: just no preview email showing up.
  4. Done that. I think I can rule that one out.. plus again, the campaign email is coming through fine, but not the preview email…

 

Reply