Solved

Abandon Cart Flow - Product links not working


Badge

Hi there,

A few months ago I noticed the products linked in my abandoned cart flows were taking users to a ‘page not found’ screen. I saw it was due to a ‘/’ missing from the URL. 

I revised my product code to {{ organization.url }}/products/{{ item.product.handle }} and that seemed to fix the issue. 

Recently, I tested my abandon cart email again and noticed the url the product link is taking users to has switched back to: theunistore.com.auproducts (missing a ‘/’). I have not edited my product code since the last time I fixed it so have no idea what’s causing the problem.

Thanks in advance for your help!

 

 

icon

Best answer by david.to 27 April 2021, 16:50

Hey @vickieex 

Adding to @caroline’s comments, one solution that may be easier than adding the “/” manually within all your email templates’s button and product title syntaxes - which may get strenuous - would be to update how Klaviyo is recognizing your {{ organization.url }} syntax.

In this case, if you updated your Organization URL within your Account settings to include this “/” so that your website reads “example.com/”; then those dynamic links within your Abandoned Cart emails would automatically amend this “/” when rendered. This strategy is further highlighted by @shoshana.antunes in the follow Community Post: 

Let us know how this goes!
- David

View original

19 replies

Userlevel 6
Badge +4

Hey @vickieex 

Adding to @caroline’s comments, one solution that may be easier than adding the “/” manually within all your email templates’s button and product title syntaxes - which may get strenuous - would be to update how Klaviyo is recognizing your {{ organization.url }} syntax.

In this case, if you updated your Organization URL within your Account settings to include this “/” so that your website reads “example.com/”; then those dynamic links within your Abandoned Cart emails would automatically amend this “/” when rendered. This strategy is further highlighted by @shoshana.antunes in the follow Community Post: 

Let us know how this goes!
- David

Hi @Taylor Tarpley 

Thank you for your reply. I tried everything you said, then I remembered my cart is not called cart it is called basket.

So I went into my site to the (cart) basket page and copied the URL then pasted it, in front of

https://mywebsite.com/basket/?wck_rebuild_cart={{ event.extra.CartRebuildKey }}

The word cart after my sites url worked.

All working now. I hope this might help someone else having this problem.

Have a great day.

Reestar x

 

Badge

David’s solution of adding a ‘/’ to the website URL in account settings worked.

Thanks!

If you read the feed it tells you after the domian

 {{ organization.url }}/products/{{ item.product.handle }}

it is red above.

I have done this, but product link is still without / and not working when you click on product link text. When you click on the product picture it is working, but not when you click on the product text. 

I don’t know.

Try what I did, copy your page url into the link.

Go to your website, put something in you cart/basket/bag the click on that cart/basket/bag to show what is in there. the URL at the top should say 

https//yourdomain/bag/

or 

https//yourdomain/cart/

or 

https//yourdomain/basket

depending on what you have called it

past that infront of the code 

?wck_rebuild_cart={{ event.extra.CartRebuildKey }}

so it now looks like

https//yourdomain/bag/?wck_rebuild_cart={{ event.extra.CartRebuildKey }}

 

If that dosent work, I don’t know! I am not a tech person, I make jewellery!!

But this worked for me.

Good luck, let me know if it worked

Userlevel 2
Badge +3

Hi @MaxStr

 

Welcome to the Community! @Reestar has been an absolute rockstar for jumping in here to help a fellow user! As they stated above, there are two options to make the link operational. 

 

  1. You can navigate to Account > Contact Information > Organization > Website URL and from here add a ‘/ ’ to the end of your website domain. Changing the Website URL from www.yourwebsite.com → www.yourwebsite.com/    Make sure you Update or Save the information.
  1. You could follow @Reestar’s instructions for what worked for her. When you navigate to your website’s abandon cart page, copy the URL, ensuring that there is a ‘ / ’at the end of it. It could look like ether of the three options they pointed out above, where the word for ‘cart’ be replaced with ‘basket’ or ‘bag’ according to your website. Copy and paste this in front of your abandon cart code:  ?wck_rebuild_cart={{ event.extra.CartRebuildKey }} .The end result should look like the code below. Make sure you Update or Save the information. Be sure your code is formatted perfectly, and there no additional spaces or letters.

www.yourwebsite.com/basket/?wck_rebuild_cart={{ event.extra.CartRebuildKey }}  

 

 

Additionally, if your website is in a different language, you will need to translate the word ‘cart’ into your website language and replace the English word for cart in your URL.  I have seen other customers manually format their URL’s perfectly, however, needed to translate ‘cart’ in order for their link to properly function. For instance, in German it would look like

www.yourwebsite.com/wagen/?wck_rebuild_cart={{ event.extra.CartRebuildKey }}  

 

Let us know if this helps! 

 

Best,

Taylor 

Hello there @caroline @david.to 

I am having the same problem, the code that was in the templete of Abandon Cart 

{{ organization.url|trim_slash }}/cart?wck_rebuild_cart={{ event.extra.CartRebuildKey }}

Is senting to a page not found page.

This code/link is different to the ones above as they say proudct in them.

I have a woocommers website. Could someone please advice me what code/link to use to take my customers to their abandoned cart within my website?

Could you also advice the code/link when in browse adandonment as the templete gave me

 {{ event.Url }} which dosn’t work either.

Really looking forward to your reply and getting all this set up.

Thank you in advance.

@david.to

I just read another feed in the forum, where you gave the link

{{ organization.url }}cart?wck_rebuild_cart={{ event.extra.CartRebuildKey }} to solve the problem so my Adandon Cart email. Is this right for woocommers.

many thanks

Hi @caroline  @david.to 

I have now tested all the links in this chat for Abandoned Cart Button, with the extra ‘/’ but NONE of them work for me. They go to page not found or a blank page. Please help.

Many Thanks

Userlevel 2
Badge +3

Hi @Reestar

 

Thank you for sharing your question with us and for joining our Community Forum! We are so happy to help you and congrats on completing your first post!

 

Sorry you’ve been having so much trouble with your Abandon Cart email! When troubleshooting, it’s important to note a few things here and take a couple steps back to see what went awry. First, each integration has a unique setup so it is important to look up specific Help Center Articles and Community Posts specific to your integration. For example, WooCommerce’s Browse Abandonment Flow is different than other integrations because the WooCommerce plugin automatically installs the ‘Viewed Product’ snippet used in this specific flow. If you’re running into problems with the ‘Abandon Cart’ Link and setting up the ‘Browse Abandonment’ Flow, I would first ensure that you are in fact using WooCommerce as an integration and that your plugin is up to date on the latest version of WooCommerce! 

 

Second, I would double check to ensure that we are in the correct flow, which is triggered by a WooCommerce ‘Started Checkout’ metric. As found in this article, Integrating with WooCommerce, this specific integration’s URL for Abandon Cart should look like the URL your last message, manually adding the ‘/’ before ‘cart’:

{{ organization.url }}/cart?wck_rebuild_cart={{ event.extra.CartRebuildKey }}

 

To verify that you’ve set up the link correctly, make sure there is not additional formatting happening when you copy and paste the URL and test the it by adding this link to the end of your website domain:

 ExampleWebsite.com/cart?wck_rebuild_cart={{ event.extra.CartRebuildKey }}

 

The reason why your cart link might not have worked originally is because your organization’s URL in Account Settings might not have a ‘/’ at the end. As @david.to stated earlier, the ‘organizational. url’ tag dynamically pulls from the URL in Account settings.

 

Additionally, if your website is in a different language, you will need to translate the word ‘cart’ into your website language and replace the English word for cart in your URL. I have seen other customers manually format their URL’s perfectly, however, needed to translate ‘cart’ in order for their link to properly function. 

 

Thank you for sharing your question in the Community! 

 

Best,

Taylor 

 

 

 

 

Userlevel 2
Badge +3

@Reestar

 

Thank you for sharing your workflow with us! It is so helpful to any future Community users who are also experiencing the same problem! 

 

So glad to hear it’s working!

 

Best,

Taylor 

Userlevel 5
Badge +4

Hi there,

 

Thanks for sharing with the Community! Is it possible that you did not save the changes the first time you edited the URL structure?

 

Best,

 

Caroline

Badge

Hi there! 

I did save the URL structure as it was working for several weeks post edit when I tested it. When I clicked ‘edit’ the link was still the revised link. It just no longer works in the emails sent out.

Userlevel 5
Badge +4

Hi @vickieex,

Just to make sure I’m understanding correctly, the structure of the URL in the template is still “{{ organization.url }}/products/{{ item.product.handle }}”, but the first slash mark is removed when the URL renders?

Best,

Caroline

Badge

Hi Caroline,

Yes that’s correct. Not sure why the slash mark is removing itself but it’s causing all product links to break when the abandoned cart email gets sent to customers.

I have the same problem. Where excactly in the account settings can I put the “/” after my domain-name?

Hi, / Yes put it after the your domain-name or what I found that worked better was going to my cart/basket page on my site and coping and pasting the page url in front of the code.

https://mywebsite.com/basket/?wck_rebuild_cart={{ event.extra.CartRebuildKey }}

https://mywebsite.com/basket/ this is from your site

?wck_rebuild_cart={{ event.extra.CartRebuildKey }} this is the code from Klaviyo so put them together. It worked for me, as in my url it said basket not cart which was the demandin the link which would never work for me​​​​​​.

 

Good luck :)

Thanks, but where exactly after the domain-name?? Can you tell me all the steps how I come to my domainname, where I can put the / after it?

Reply