Solved

Order Confirmation, not received and address not shown

  • 15 April 2021
  • 5 replies
  • 21 views

Badge

Hi,

Today I made a sale by myself in my store, but I realized that I didn´t receive the email from Klaviyo, I received it from Shopify automatic email. All the Order Confirmation flow are live, I don´t know why I didn´t received it from Klaviyo.

And also, on the address details it only shows the first row of the adress, I can only see the street name, I can not see the rest of the number and flat number.

Can someone help me, please?

Thanks!

icon

Best answer by zyzl91 16 April 2021, 21:26

Hi @zyzl91,

Thank you for sharing your question with the Klaviyo Community.

With respect to your first question,I have a couple of solutions for a similar situation in my reply here. I recommend checking this out first. Please do let me know if this does not resolve your issue.

With respect to your second question, can you try inserting the following tag into your email where you want the flat number to display:

{{ event.extra.billing_address.address2 }}

this is the tag that will include the suite/flat number.

 

Thanks and have a great weekend.

Hi, thanks for the reply,

 

I was also thinking if I need to turn off the automatic email notification in Shopify, could this give a problem to the Klaviyo flow?

View original

5 replies

Userlevel 4
Badge +3

Hi @zyzl91,

Thank you for sharing your question with the Klaviyo Community.

With respect to your first question,I have a couple of solutions for a similar situation in my reply here. I recommend checking this out first. Please do let me know if this does not resolve your issue.

With respect to your second question, can you try inserting the following tag into your email where you want the flat number to display:

{{ event.extra.billing_address.address2 }}

this is the tag that will include the suite/flat number.

 

Thanks and have a great weekend.

Badge

Hi @zyzl91,

Thank you for sharing your question with the Klaviyo Community.

With respect to your first question,I have a couple of solutions for a similar situation in my reply here. I recommend checking this out first. Please do let me know if this does not resolve your issue.

With respect to your second question, can you try inserting the following tag into your email where you want the flat number to display:

{{ event.extra.billing_address.address2 }}

this is the tag that will include the suite/flat number.

 

Thanks and have a great weekend.

Hi, thanks for the reply,

 

I was also thinking if I need to turn off the automatic email notification in Shopify, could this give a problem to the Klaviyo flow?

Userlevel 4
Badge +3

Hi @zyzl91,

Thank you for your follow-up note.

Shopify’s email notifications, like for their order confirmation flow and Klaviyo’s order confirmation emails, operate completely independently from one another. So you would not have any issues disabling Shopify’s order confirmation email in favor of Klaviyo’s.

Thanks and have a great weekend.

Badge

Hi @zyzl91,

Thank you for your follow-up note.

Shopify’s email notifications, like for their order confirmation flow and Klaviyo’s order confirmation emails, operate completely independently from one another. So you would not have any issues disabling Shopify’s order confirmation email in favor of Klaviyo’s.

Thanks and have a great weekend.

Hi dov,

thanks for the reply.

I want to know how can I turn them off, because there isn´t the option to disable it in the settings of the notifications.

 

Userlevel 4
Badge +3

Hi @zyzl91,

Thank you for your reply.

After doing some digging, it appears that Shopify only allows you to disable certain types of notifications however, this does not include the “Order Confirmation” email. In light of this information, you may be well advised to disable our order confirmation in favor of Shopify’s to avoid duplicate emails being sent out.

Thanks and have a great day.

Reply