Solved

Why is my Embed Form not Appearing on my Shopify Site?

  • 24 November 2020
  • 4 replies
  • 1545 views

Badge +2

Hi there,

 

Having an issue where my embed form is only showing up about half the time on page load. I’m not sure what the issue is. It’s a Shopify site and I have synced the 2 products and placed the embed code on the html. The form should show up in the footer and on this page: https://thewineconnection.com/pages/birthday

Any help is appreciated. At a loss here. 

Thank you!

 

 

icon

Best answer by k.mcevoy 24 November 2020, 18:46

View original

4 replies

Userlevel 4
Badge +6

Hi @DynMtk

 

Thanks for reaching out! Happy to help out here.

 

Taking a look at the javascript loading on the page it looks like you have two Klaviyo web tracking snippets connected to two different Klaviyo accounts:

 

Having these two scripts loading on the same page can impact whether the Klaviyo forms load. It looks like one of those snippets is attached to a free account (ID T8fgzH). I recommend removing that script and seeing if that allows the form to load consistently. 

 

Let me know if you have any further questions on this and I would be happy to help!

 

Kelsey 

Badge +2

That worked! Thank you.

Badge

Hello, we seem to have two separate “company_ID”= values and I believe this is causing a signup form to not load. I can't find where to edit the code to remove the duplicate tracking JS file, can someone please help with that?

Userlevel 7
Badge +56

Hello @BerniesBest,

Thank you for your follow-up.

Yes, having two separate scripts of Klaviyo’s onsite js can impact the ability for Klaviyo sign-up forms to load. In order to fix this, you’ll want to reach out to support for assistance to remove one of these scripts.

Reply