Solved

SMS "No Phone Number" Post Sign Up Form

  • 7 February 2023
  • 4 replies
  • 231 views

Badge +1

I have a phone number and consent block on my sign up form, but when I get the numbers it says “No Phone Number” as the reason for a skip. But then when you look at every phone number profile, it has the number attached and consented on their profile.

 

I’m not sure why it’s skipping and thinking it’s not a real number? Any ideas on why this is happening? It’s happening to every number I get through my sign-up pop up.

 

 

icon

Best answer by David To 7 February 2023, 18:02

View original

4 replies

Userlevel 1
Badge +3

Hi @bennyshades! Mirko here 😄

I'm here to help with your SMS sign-up form issue. Let's see if we can resolve it together! 🙌

  1. First, let's make sure the phone number field on the form is correctly labeled as "Phone Number".

  2. Double check that the phone number is entered in the proper format, including the country code.

  3. Make sure the consent block is properly set up and labeled as "Phone Number Consent".

  4. We want to confirm that the form is submitting the phone number data to the correct field in your Klaviyo account.

  5. It's always good to make sure pop-up blockers or firewalls aren't interfering with the form submission process, so let's turn those off if they're enabled.

If after trying these steps you're still having trouble, don't hesitate to reach out for further assistance.

I'm here to help! 😄

Userlevel 7
Badge +60

Hey @bennyshades,

Adding to all of @bettermail-Mirko’s suggestions, is your SMS message at the beginning of your flow? If so, do you happen to have a time delay between the trigger and this message? 

Depending on how things are setup, sometimes SMS consent and/or a phone number may not be recorded in time when your subscriber triggers a flow. In my experience, this most commonly occurs if the following conditions are met:

  • you’re using a multi-step signup form
  • have single opt-in enabled on your list
  • serving both email and SMS in your welcome flow
  • do not have a time delay between your trigger and your messages

With single opt-in enabled, users who subscriber to the first email step of the multi-step form would immediately trigger the flow. Without a time delay between your trigger and the message, it does not give enough time for your subscribers to provide a phone number and consent to SMS. 

You can check if this was the case by reviewing the timestamp of when that particular subscriber was skipped from the message versus their consent timestamp on their profile. 

Using double opt-in or time delay in the flow are typically the easiest way to alleviate this sort of behavior. 

David

Badge +1

@David To  You nailed it! I met all those conditions and that did the trick by adding a time delay. 

 

Thanks so much!

Hi @bennyshades , where did you apply the time delay? I am having the same issue!

 

Reply