Solved

Emails go into spam but not all

  • 15 March 2022
  • 2 replies
  • 155 views

Badge +2

Hi team,

 

I have a problem with spam. I already read all relevant topics but still would love to have a clearer explanation from Klaviyo.

So we currently use info@mycompany.com as a sender name (hide the domain name for privacy). No matter when we send a preview inside a campaign or send the campaign to our colleagues’ emails like henry@mycompany.com or selina@mycompany.com), the emails will end up in Spam. They’ve been interacted with the emails like open and click.

Could you please explain why this hapened?

Thank you very much.

icon

Best answer by David To 16 March 2022, 15:18

View original

2 replies

Userlevel 7
Badge +58

Hello @Lavender,

Welcome to the Klaviyo Community!

I know you had mentioned you had read several posts on this subject, but did you get a chance to take a look at the below Community post written by @wei.he, a member our Klaviyo Deliverability team members?

Depending on how stringent your inbox security and settings are, these emails sent to your internal team members may end up in the spam folder rather than being fully blocked. This is also mentioned in the Why Some Preview Emails Go to Spam Help Center article. In addition, similar to the point made by Wei, if you transitioned from a different ESP and previously had a dedicated sending domain set up or your domain was verified, you’ll want to also have that set up within Klaviyo if you haven’t already. 

I would suggest speaking with your internal IT administrator and see if this was an issue that can be resolved through making some adjustments within your inbox security settings or if utilizing a dedicated sending domain is the right decision for you. You can learn more about deliverability and setting up and using a dedicated sending domain from the following Help Center articles:

 

 

 

I hope this helps!

David

 

Badge +2

Hi David,

 

Thank you very much for your detailed explanation.

Will check out all resources you shared. 

Reply