Solved

Event triggered flow does not work

  • 7 August 2022
  • 6 replies
  • 510 views

Badge +1

Hi all,

I have an event triggered flow where a user gets an email after our completed job event, and the trigger is that a customer parameter (warranty) does not include 3 different values. I also added a flow filter where the user must not be suppressed. (the images show the flow filter deleted to see if that would fix my issue).

After 30 days, I want to record their activity by adding a conditional split custom parameter to their profile to mark their engagement (I know I could also do this in a segment, but I wanted a profile parameter value so I can use that with other parameter values in later automation flows).

So far, I have 600+ folks going through the flow without an email being sent. And the conditional split won’t work if the users never got the email to begin with (hence why the custom parameter isn’t completed since there’s no metrics to populate from the email).

I took out the suppressed email to see if that will work, but wanted to get the community feedback and see if there is something I missed (which I am sure there is). I’m not new to Klaviyo, have used it in previous companies, but I’m more of a Marketo guy … 😁

Any advice is appreciated! (or if you need more deets, kindly let me know).

 

 

icon

Best answer by Dov 17 August 2022, 17:56

View original

6 replies

Userlevel 7
Badge +61

Hi @davidatWR,

Thanks for sharing this question with us.

Based on your screenshot, I see the email is in draft mode, unless the email is in manual or live mode, users will immediately proceed past the email and be queued up for the conditional split.

For more information on email statuses have a look at our article here.

I hope that’s helpful. 

Badge +1

Hi Dov, Sorry I put the email on draft prior to the screenshot as I was trying to troubleshoot the issue.

Userlevel 7
Badge +61

Hi @davidatWR,

Ok thanks for that information.

I don’t see anything wrong with the trigger filter set-up. The trigger filters would be excluding users before they entered the flow so anyone who entered the flow (and thus passed through the conditional split) would have met the criteria and in theory should have also received that flow email.

When you click into the flow email itself using the “View all Analytics” on the left, do you see any other data? In particular, are there any skip reasons? If the analytics are completely blank over all time, it means the flow email was in draft mode when users were passing through the email. 

If there are skip reasons, those will give you more insight into why they never received that email i.e. a previous filter that was there or another reason.

In terms actually of fixing this, (if indeed nobody ever received this email) you can clone the flow and backpopulate it. I explain how back-populating metric-triggered flows work in the thread below:

Alternatively, you can save that flow email as a template and send it as a campaign to a segment of people that mimic the trigger filter/event trigger criteria i.e. what sombody has done > Completed Job AND Warranty flag doesn’t equal X and Y and Z. This strategy will only work if the flow email does not contain any dynamic event data about their product i.e. dynamically displayed item name, price etc. If it does, you’ll want to use the first backpopulation method.

I hope that’s helpful.

Badge +1

@Dov Thanks for the detailed info. Actually the emails were live; I can see in the flow history when the email went live, what I changed to fix the issues, when I changed the emails to draft mode and back to live mode, and what I removed in the flow.

I did not see any skip reasons -- I honestly didn’t pay attention, if there were any. 

I went ahead and talked to a Klaviyo rep to figure this out, since it’s critical for this to start. Hope to hear from them soon...

Badge +1

UPDATE:

Spoke with a Klaviyo rep and he mentioned we are having timestamp issues. Apparently, there's too much time between the time our event is timestamped and the time it's making it into Klaviyo.

If there is more than a 4 hour gap our flows will not trigger as we think these are backfilled events.

I’ve actually decreased the sync lag, so now our system pushes information into Klaviyo every 5 minutes. I’m still not seeing people go through the flow.

Any advice @Dov? I’m at a loss, and the rep isn’t helpful at this point...

Userlevel 7
Badge +61

Hi @davidatWR,

Thanks for the update here.

Just to ensure we’re on the same page, from what your describing here, you’re seeing the “Completed Job” event logged in your Klaviyo account if you check in Analytics > Metrics (if you’re not seeing the events appearing here first, this would signal an integration issue rather than an issue with the flow). 

So assuming that’s happening, and without any recipients in the flow itself, the issue will either lie with the trigger filters i.e. people genuinely do not qualify for the flow (which doesn’t sound like it’s the case), or if the timestamp is the issue (larger than a 4 hour gap between the timestamped date + time and the recorded date + time for the event), I recommend continuing to correspond with our support team on this matter asking for advice on how to remedy this gap in time (otherwise we won’t be able to trigger the flow) - I’m hopeful they’ll have some further technical advice for you. I’m not a developer myself, but we have technical experts that may be able to shed more light on this.

You can also try out the campaign method I outlined in my previous reply if that is applicable in this case (i.e. the flow email does not contain any dynamic event data about their product i.e. dynamically displayed item name, price etc.)

I hope that’s helpful.

Reply