Solved

New to klaivo, need help with simple flow automaton

  • 24 August 2023
  • 6 replies
  • 48 views

Badge

Hey guys!

I need 1 simple automaton for my shopify store. When someone places and order for a service i need to send them a custom email for that service.

So in Klaivo app i added the following : 

 

trigger When someone place order
trigger setup filter : when items equals “name of the service” as text
Configure delay 1 minute
Email : the custom email

The email is never sent. Can anyone help me figure this out?

Thank you

icon

Best answer by bluesnapper 24 August 2023, 17:13

View original

6 replies

Userlevel 7
Badge +39

 Welcome to the community @RocKyBalboa 

If your are using a ‘Placed Order’ event as the trigger, then the trigger filter is Type: List and then ‘items’ contains ‘name of the service’ from the drop-down of values that appear (pulled from your orders). See below example.

Klaviyo stores the items in an order as an array (as here can be many items) which is why the Type is ‘List’. List is the default Type for a placed order trigger.

Alternatively, you could create an ‘Ordered Product’ event as the trigger with ‘Name’ equals ‘name of the service’ and that would be Type: Text; Klaviyo captures each of those events for every product in an order.

Hope that works for you.

Regards

Andy

 

Badge

Hello there,

Thank you very much for the fast reply.

I tried it and it didnt work. I then tried a very basic flow with placed order → order confirmation and this didnt work either. I receive the shopify emails but never the klaivo email. 

Is there some sort of setup i need to do before this flow works? Is it because im on the free plan?

 

 

Userlevel 7
Badge +39

Hi @RocKyBalboa Have you confirmed you are receiving placed order events in Klaviyo?

Regards

Andy

Badge

@bluesnapper hello friend,

yes i do receive events (i think)

I just reset it and tried it again. My test shows as 1 deliveries
 

 

Badge

It was in spam xD

#facepalm

 

thank you

Userlevel 7
Badge +39

No problem. I’m glad it’s now working for you :-)

Regards

Andy

Reply