Solved

Only flow emails get clipped, campaign emails send fine

  • 29 November 2021
  • 1 reply
  • 44 views

Badge +1

Hey y’all,

Couldn’t find any insight in the community on this. But it seems that the same email from a campaign does not get clipped in Gmail, whereas the same exact template with the same exact content does get clipped from a flow email. We’ve done enough research and found all the emails are under the KB limit and also audited them for spam words, KB size (after sending), and non-ASCII characters.

 

Is it at all possible that Klaviyo is adding a non-ASCII character (source 1 and source 2) making Google act up? We found that removing a copyright symbol from previous emails completely removed clipping in campaign emails but there seems to be some witchcraft happening from flow emails specifically.

icon

Best answer by Dov 30 November 2021, 21:56

View original

1 reply

Userlevel 7
Badge +56

Hi @pete,

Thanks for sharing this with us.

This is unusual indeed. There’s nothing inherent about non-ACSII characters in flows that would cause the email to clip (that wouldn’t apply to campaigns). What comes to my mind is any additional settings enabled specifically on the flow email that isn’t present on the campaign email, for example, UTM parameters adding to the size of the email.

Also, if you ran lots of tests from the same email template, and the message becomes threaded in your inbox, it can reach a size large enough that Gmail would clip it. I’d test the email template again (in both a flow and campaign) with a new subject line to rule that out. If you still have trouble after this, I recommend creating a support ticket and leave a note in there that you’re looking to have this addressed by the templates team who can have a closer look at the email itself. Also let us know if one of the aforementioned solutions works for you :)

Hope that was helpful!

Reply