Solved

Why Can't You paste and match style in the New Editor?

  • 6 April 2022
  • 3 replies
  • 340 views

Badge +3

We have only just started using the new template editor. 

 

I make 5 different emails for one campaign, all in different languages. What used to be awesome with the classic editor was that I could paste and match style (I have a mac) from our translations document into the Klaviyo editor and then I wouldn’t have to mess around with setting the font size and choosing the formatting options. 

 

The new editor, when I command > right click just comes up with an option to “link” or “command > K”. Meaning I can’t now paste and match style and I have to format the text on every email. 

 

I know it’s a small moan, but it used to save a LOT of time. Has anybody else noticed this on the new template editor and now how to fix it? 

icon

Best answer by Caris F. 8 April 2022, 11:02

View original

3 replies

Userlevel 7
Badge +60

Hi @Caris F.

 

Welcome to the Community! Thanks for sharing your experience you’re had with the new template editor. No moan is a small moan here, thank you for sharing! 

 

Yes, unfortunately, this is a new feature of the editor for a reason and can’t be fixed per say. The new editor removes external styles when pasting content in as this is actually a best practice. Allowing content to be pasted in to match external styles is  known to cause style discrepancies. It is best to paste in plain text and then style them with Klaviyo tools (block styles).

 

However, to save you time, you could save your template blocks after you styled them or investigate setting a font to stylize your entire template using “Styles”. Both these workarounds could save you the time of individually stylizing each block for each language templated

 

Thanks for participating in the Community! Hope this helps! 

-Taylor 

Badge +3

 Hi Taylor,

 

Thanks for the welcome! 

 

I’m not sure I explained myself properly, no worries! So I was trying to paste and match the internal style so that the text I was pasting was appearing in Klaviyo the same way that my styled, saved block appeared. I don’t know if that makes sense. 

I’ve found a workaround now so don’t worry! 

 

Thanks!

Userlevel 7
Badge +60

Hi @Caris F.

 

Glad to hear it was resolved, thanks for the additional clarity. 

 

Do you mind sharing out your workaround process as it could possibly help a future user with the same issue? 

 

Thank you!

-Taylor 

Reply