Why is there a gray border showing in my email template?

  • 7 December 2020
  • 4 replies
  • 1801 views

Badge +2

If you copy and paste directly from a third-party resource such as a Word doc or website, a border and additional HTML can be copied over as well. Not just the text itself.

Look for <!--td {border: 1px solid #ccc;}br {mso-data-placement:same-cell;}→ in the source of one of your text blocks (it's possible that it's in multiple) and remove it.


4 replies

Badge +1

We have the same issue but the only copy and paste we’re doing is when inserting hyperlinks so that shouldn’t be causing the extra HTML, should it?

Userlevel 7
Badge +61

Hi @Splendette,

Thanks for your question.

Just inserting hyperlinks will not add any additional styling to create grey borders. With that said, a border could’ve been added inadvertently, say if you had other individuals working on the template that did copy/paste something at some point. I would search each block in your email template for any source code calling for a border (like what Bridget mentioned above) and remove it to resolve the issue. Here’s an example of what that code would look like in a Table Block, for example:

 

 

 

Ideally, any content taken from another source is "pasted as plain text" to avoid this from happening. That can be achieved by pasting content using the button outlined in the screenshot below:

 

 

 

Badge +1

We only have one person that uses Klaviyo and they definitely haven’t pasted any content. Everything is written directly into Klaviyo. This issue only started yesterday, we’ve used Klaviyo successfully for months.

Userlevel 7
Badge +61

Hi @Splendette,

Thanks for providing that update and for the clarification.

I still recommend looking through the source code and removing the styling that is causing this border to appear. Also, consider cloning the template first and working with the clone as you remove the border styling (just in case you want to test out some things and/or if you make a mistake). That way, you’ll still have the original email, and you can re-clone it for further testing if need be.

I also recommend previewing this email in different email clients and on both desktop and mobile, to see if the grey border is consistently on display or not.

If you’re still having trouble after trying the above, please let us know.

Reply