Solved

Klaviyo not integrating with woocommerce

  • 13 February 2022
  • 14 replies
  • 714 views

Badge

I have not been able to integrate klaviyo to woocommerce. I have been getting errors for days. I deactivated some plugins but it still gives the error. Please how can you resolve this???

The Error: We encountered an error while attempting to establish an integration between WooCommerce and Klaviyo. To resolve, please review the troubleshooting steps outlined in our Help Center. Details: Non 200 Response Received

icon

Best answer by Dov 23 February 2022, 19:23

View original

14 replies

Userlevel 7
Badge +55

Hi @charles111,

Thank you for sharing this question with us.

If you have any firewalls or security layers set up on your site, you are likely getting blocked from integrating due to Klaviyo getting denied by your security. I recommend working with your hosting provider to ensure that requests to Klaviyo's custom endpoints at /wp-json/klaviyo/v1/* are allowed. That should remedy the issue.

I also recommend whitelisting our user agent which is "Klaviyo/1.0”.

I hope that is helpful.

 

Badge

thanks but it is not still working. i contacted hostgator support but they cant do anything about it. Not sure what to do, klaviyo support has not replied my email.

Userlevel 7
Badge +55

Hi @charles111,

Sorry for the wait, you will get a response from our support team shortly.

I recommend cc’ing Hostgator support in your ticket with our support team so they can discuss further. Please provide what you’ve tried already, you can even include a link to this forum post for simplicity.

Thanks for being a member of our community.

I’m having the same problem :(

Userlevel 7
Badge +55

Hi @TopPad,

Sorry to hear about this, can you please file a ticket with our support team and cc your hosting provider in the email? Our team will have a closer look at your integration for you.

I have the same problem, using cloudflare, and enabled klaviyo agent through firewall, but no luck. 

Userlevel 7
Badge +55

Hi @dejans,

Thanks for your message.

In addition to my first recommendation:

Hi @charles111,

Thank you for sharing this question with us.

If you have any firewalls or security layers set up on your site, you are likely getting blocked from integrating due to Klaviyo getting denied by your security. I recommend working with your hosting provider to ensure that requests to Klaviyo's custom endpoints at /wp-json/klaviyo/v1/* are allowed. That should remedy the issue.

I also recommend whitelisting our user agent which is "Klaviyo/1.0”.

I hope that is helpful.

 

I encourage you to try the following steps:
1. Delete the WooCommerce integration in Klaviyo
2. Delete the Klaviyo plugin in your WordPress
3. Re-install the plugin
4. Log into Klaviyo via an incognito window and re-add the WooCommerce integration

If you’re still having difficulty after this, please reach out to our support team for further assistance.

Any update on this issue or other steps? What is the non 200 response being sent in theses cases as our server logs don’t show any 40x or 50x errors during connecting of the integration.

 

I’m having similar problems and haven’t been able to connect after trying all the steps above and contacting my hosting company as well.

 

Thanks!

Also having the same issue here. I spoke with an account rep over 3 weeks ago when setting up my account, they said support would get back to me, and it’s been crickets ever since. Emailed the rep again a week ago and still no response. Not happy with the lack of support considering this is the second business I’m setting up with klaviyo.  This account also uses hostgator, as someone else previously mentioned, and can not find out what is causing the non 200 error. I really need this resolved, as our season is less than a week away from starting. Thank you.

Update: Klaviyo support fixed the issue, thanks and big shout out to Jeffrey! It had to do with mod_sec something or other… while I’m sure this is not very helpful, I recommend filing a support ticket and they will be able to help you. Blue Host was my issue.

 

PS. I’ve always received a reply from Klaviyo support within 24 hours ANY time I’ve filed a support ticket, and I’ve worked with Klaviyo with 3 businesses over 6 years. You guys are awesome.

Badge

Anyone have this issue with their website being hosted on Bluehost. I’m currently getting this same error and Bluehost says they can’t whitelist a user agent. 

Userlevel 7
Badge +55

Hi @karidahlgren,

I’ll pass your feedback on to our wonderful support team I’m sure they’ll be delighted to hear it :)

@duckfoxnet I’d recommend doing the same (contacting support) and looping in Bluehost into the ticket thread if necessary to coordinate a response.

 

Badge

Hey @Dov Is there an IP address that can be used by BlueHost to whitelist? 

Userlevel 7
Badge +55

Hi @duckfoxnet,

You should try whitelisting our user agent which is "Klaviyo/1.0”, since we rotate the IP addresses dynamically making it difficult to whitelist a specific IP.

Reply