Solved

Why can't I connect klaviyo to wordpress - 404 page after install?

  • 22 June 2022
  • 2 replies
  • 34 views

Badge +2

Hey
I downloaded Klaviyo and installed it on the site (not the first time I do this) and for some reason when I try to click activate it leads me to page 404.
What is being done to solve this? Klaviyo's support seems to be missing underground :(

icon

Best answer by Taylor Tarpley 22 June 2022, 16:45

View original

2 replies

Userlevel 6
Badge +51

Hi @zeremitay

 

Welcome to the Community! Sorry to hear you’re experiencing this issue, would love to get to the bottom of this with you. 

 

There could be many why you’re getting a 404 error page. From my experience, this issue can definitely arise if  Permalinks isn’t enabled for this WordPress site. Woocommerce authentication will not work unless Permalinks are enabled.
 However, if you believe your Permalinks are being enabled, however you’re still experiencing the issue, I would investigate the following options:

  •  not activating mod_rewrite on your local server. There shouldn’t be a # in the code below, if so, removing it might solve the issue:
 # LoadModule rewrite_module modules/mod_rewrite.so
  • selecting ‘Custom Structure’ instead of ‘Plain’ in your permalinks structure page
  • needing to update your apache virtual host file if the AllowOverride is defaulted to None.
  • the URL where you are receiving the 404 error is using "%2F" instead of "/": which will need to be replaced

 

I suggest investigating all of these potential issues as a fellow Community member also had the same issue, but had success when changing from Custom → Plain structure in his Permalinks setting page.

 

Thanks for participating in the Community!

-Taylor 

Badge +2

yesss thank youu!

Reply