Solved

Woocommerce periodic sync has failed

  • 8 June 2021
  • 3 replies
  • 97 views

Badge

“Your WooCommerce integration's periodic sync has failed.

Klaviyo is no longer authorized to connect to WooCommerce.

Please check WooCommerce and update your settings to re-enable sync. If you have any questions, please contact our Success Team.”

 

  • I have used the public API key.
  • Setup exactly as followed in the video tutorial.

Can anyone point me in the right direction to fix this issue ASAP?

Thanks!

icon

Best answer by david.to 8 June 2021, 22:09

View original

3 replies

Userlevel 6
Badge +4

Hello @Luke Adams,

Welcome to the Klaviyo Community!

Since the error message you highlighted is pointing to an authorization error, I would first recommend ensuring that the user assigned in the REST API was set to Admin with Read/Write permissions. Another common issue that may cause this error is if you happen to have a firewall that may be prevent Klaviyo from initiating this sync. This can be resolved by listing “Klaviyo/1.0” as an acceptable user-agent for all requests to avoid this firewall issue. 

Lastly, I would also recommend ensuring that you are on the most up to date plugin/extension version. At this time, the most up to date Klaviyo plugin version is 2.4.1. You can download the latest Klaviyo WooCommerce plugin version manually from the Wordpress store. 

All of these points I mentioned are also elaborated further the below Community posts which touch upon this subject of receiving an integration error:

Hope this helps!

David

Badge

One more thing what country are the Agents coming from since it looks like there are country blocks in place also.

Userlevel 6
Badge +4

Hey @adavenue,

A user-agent ID such as the Klaviyo/1.0 user-agent mentioned is an identifier of where the requests are coming from. Similar to a signature associated with the calls or requests. There wouldn’t be any location data associated with this user-agent signature itself. 

As such, since the user-agent is just a signature applied to the header of your calls or requests, there isn’t any specific country blocks in place for the user-agent itself. If you were running into an issue with your calls and requests getting block, despite listing the Klaviyo/1.0 as a user I would recommend reviewing your firewall and the settings you have in place. 

I hope this helps!

David

Reply