Solved

Trouble with klaviyo integration with magento 2.4.3

  • 3 November 2022
  • 1 reply
  • 501 views

Badge +1

I am having trouble with the integration with my Magento 2.4.3. I installed the module without problems. I named the integration klaviyo and when i try to activate the integration, this is the error i get: 

Klaviyo is unable to connect to Magento Server for OAuth Handshake.Url tried was: https://pro2a-tactical.com/Please ensure that both /oauth/token/request and /oauth/token/accessare accessible
icon

Best answer by Brian Turcotte 4 November 2022, 18:02

View original

1 reply

Userlevel 7
Badge +36

Hello @pro2a and welcome to the Community!

 

This is an issue that appears semi-frequently in the Community. It may be helpful to first take a look at our How to Setup OAuth for Existing Magento 2 Integrations article to ensure you’ve accurately updated your existing Magento 2 integration from API credential authentication to the new OAuth workflow.

 

Additionally, here are some Community threads that have addressed similar issues, where other members have found solutions:

 

As my colleague David mentioned in that first linked thread, issues like these are directly related to your integration, so it may be helpful to reach out to our wonderful Support colleagues who can potentially point you in the correct direction by identifying any blatant integration issues.

 

I hope this helps, and thanks for being a Community member!

 

-Brian

Reply