Solved

Import succeeded but users not entering flow

  • 2 October 2021
  • 4 replies
  • 47 views

Badge

I created and uploaded archive data as instructed in the help section.  The import appeared to complete with error.  And then nothing. No added customers, no statistics change in flows, no confirmation and/or failure email.  Just silence.

It seems that importing ~300 record should be relatively quick, and provide some indication of success. What have I done wrong?

Also, if anyone is interested I created an export template for Shipworks.

icon

Best answer by Dov 4 October 2021, 21:26

View original

4 replies

Badge

Update: My profiles now appear to have all been imported, but the flows dont show what I expect. 

There should be a large number of people now in “Thank You”, but I see only the handful who have purchased since implementing Klaviyo.

Winback appears to show all since I implemented Woocommerce (Aug 4), but none from the previous 10 months (12mo of manual import) from Miva.

 

Userlevel 7
Badge +54

Hello @OdorDestroyer.com,

Thanks for sharing this question and your update with the Klaviyo community!

Based on your description of events, it sounds like you have uploaded event data for these profiles and are now looking to target them via a flow based on their past behavior (purchase behavior or otherwise)?

If so, keep in mind that in order to put users through flows based on historical data, you will need to back-populate your flow. If it is triggered off of an event (metric), which sounds like it is in your case, please look through the thread below for more information on how this works:

If I am missing anything, or the thread doesn’t directly address the question, please provide any additional details so we can work towards a solution.

Thank you for being a member of our community.

Badge

Dov,

I did backpopulate the flow.  But the totals in the flow are far less than expected.  For example, we have a high one time purchase rate.  I imported 1000 customers/orders and backflowed the Winback which send at 75 and 90 days.  There are 150 waiting on 75 days and 120 waiting on the additional 15 days. These numbers should be more like 5-700 total.

It’s almost as if the winback script backpopulate excludes orders > 90 days.

Thoughts?

Userlevel 7
Badge +54

Hi @OdorDestroyer.com,

That is exactly correct. In the post I threaded above, there is a paragraph that speaks to this:

“There are different types of back-population depending on the flow trigger. Since you are using an event (metric) to trigger this flow, when you back-populate, users will get queued-up for the email according to where they fall in the flow’s time-delay timeline. For example, if you had a 10 day time-delay in your flow, individuals who placed an order 8 days ago would receive this flow email in 2 days. Users who placed an order 4 days ago would receive this flow email in 6 days. For metric-triggered flows, the time-delay is the time of reference for the back-population and we will not back-populate users who fall outside of that timeframe. So using a 10-day time delay for back-population would only back-populate people who placed an order up to 10 days ago.”

Therefore, if you wanted to capture users who placed orders 91+ days ago, you’d have to use a longer time-delay to accommodate those orders that happened further back in the past.

Reply