Solved

Why are new customers automatically being added to the Potential Purchasers List?

  • 2 January 2021
  • 1 reply
  • 117 views

Badge

Hello, I have set up pop-ups on my Shopify store and have noticed that customers are not going to the list which I have specified - as can be seen the image below - I have set up the pop-up sign ups to go to the “Ordrs” list, however, new sign-ups just go to the Potential Purchasers list. Why is this?

 

icon

Best answer by retention 4 January 2021, 08:30

@Davidson Hi,

The first step to resolving this issue is to understand the difference between List and Segment. A quick explanation is that Lists are static and can be populated by importing contacts or via a signup form that is connected to that List. A Segment is a dynamic grouping of people that share the same properties pre-defined in the Segment’s definitions. A Segment will scan all the profiles in your Klaviyo account and if they match the Segment’s definitions they will be added to the Segment. Read more about the difference between Lists and Segments here.

Potential Purchasers is a pre-built Segment in Klaviyo. It will capture all profiles matching these definitions:

That being said, let’s jump to more specific details about your situation.

I suspect that your problem might be the Double Opt-in process.

If you haven’t disabled Double Opt-in for your “Ordrs” list, after someone subscribes they will receive a confirmation email where they have to confirm their subscription before they’re placed to your List. A lot of subscribers doesn’t go the extra step to confirm their subscription and that’s why they’re never placed to your list.

You can test to see if this is your case by subscribing to your form (with an email address that’s not currently on the “Ordrs” list), and see if you’ll receive the “Confirmation Email” (check Promotional or even the Spam folder in your Email). If you do receive it, and after confirming you get subscribed to your “Ordrs” list, than you need to disable Double Opt-In for that List if you want to skip the confirmation email and place subscribers directly into the list after they subscribe.

Here are more details about Double Opt-In process:

The Double Opt-in feature in Klaviyo is hidden from the settings by default for free plan. If you are on a paid plan in Klaviyo, you can submit a request to enable this option for your account here: Klaviyo Contact Form.

Ask Klaviyo support team to reveal that option for you, so you can toggle Double Opt-in on and off for each of your lists.

After you get a confirmation that the option is enabled for your account, navigate to the List for which you want to turn off the Double Opt-in. Open the list and click on “Settings”. Uncheck the “Require subscribers to confirm their subscription before being added to your list.” option.
 

 

After you uncheck this option, Klaviyo will stop sending the Double Opt-in Emails to the subscribers joining that List.

Here is the documentation from Klaviyo on Double Opt-in: The Double Opt-In Process


Hope this helps!

View original

1 reply

Userlevel 6
Badge +4

@Davidson Hi,

The first step to resolving this issue is to understand the difference between List and Segment. A quick explanation is that Lists are static and can be populated by importing contacts or via a signup form that is connected to that List. A Segment is a dynamic grouping of people that share the same properties pre-defined in the Segment’s definitions. A Segment will scan all the profiles in your Klaviyo account and if they match the Segment’s definitions they will be added to the Segment. Read more about the difference between Lists and Segments here.

Potential Purchasers is a pre-built Segment in Klaviyo. It will capture all profiles matching these definitions:

That being said, let’s jump to more specific details about your situation.

I suspect that your problem might be the Double Opt-in process.

If you haven’t disabled Double Opt-in for your “Ordrs” list, after someone subscribes they will receive a confirmation email where they have to confirm their subscription before they’re placed to your List. A lot of subscribers doesn’t go the extra step to confirm their subscription and that’s why they’re never placed to your list.

You can test to see if this is your case by subscribing to your form (with an email address that’s not currently on the “Ordrs” list), and see if you’ll receive the “Confirmation Email” (check Promotional or even the Spam folder in your Email). If you do receive it, and after confirming you get subscribed to your “Ordrs” list, than you need to disable Double Opt-In for that List if you want to skip the confirmation email and place subscribers directly into the list after they subscribe.

Here are more details about Double Opt-In process:

The Double Opt-in feature in Klaviyo is hidden from the settings by default for free plan. If you are on a paid plan in Klaviyo, you can submit a request to enable this option for your account here: Klaviyo Contact Form.

Ask Klaviyo support team to reveal that option for you, so you can toggle Double Opt-in on and off for each of your lists.

After you get a confirmation that the option is enabled for your account, navigate to the List for which you want to turn off the Double Opt-in. Open the list and click on “Settings”. Uncheck the “Require subscribers to confirm their subscription before being added to your list.” option.
 

 

After you uncheck this option, Klaviyo will stop sending the Double Opt-in Emails to the subscribers joining that List.

Here is the documentation from Klaviyo on Double Opt-in: The Double Opt-In Process


Hope this helps!

Reply