Solved

SMS campaign schedule in recipient's timezone

  • 24 May 2022
  • 7 replies
  • 575 views

Badge +2

Hi all! Previously I recall sending an SMS campaign with the option to schedule time according to the recipient’s timezone. I can’t seem to find that option anymore, would anyone be able to help?

This is what I see when trying to schedule:

 

FYI recipient are in US, Canada, Aus, UK.

 

Thank you in advance.

icon

Best answer by David To 25 May 2022, 15:43

View original

7 replies

Userlevel 7
Badge +60

Hello @dani_bazzaal,

Welcome to the Klaviyo Community!

Scheduling a SMS to be delivered at a recipient’s timezone - similar to scheduling an email campaigns to be delivered at recipient’s local timezone - is absolutely supported! 

A common mistaken many users make is when wanting to schedule a campaign to be delivered at a recipient’s local timezone is they’ll manually select a specific timezone rather than select the Recipient's Local Timezone option from the timezone. Similar to what you’ve done in your screenshot. Having a specific timezone selected will essentially schedule that campaign to be sent out at a very specific time. From your example, this means that no matter what timezone your recipients are in, the campaign will be sent at 5:00pm US/Eastern. I.E. recipients on the PST timezone will be receiving this email at 2:00pm their local time. 

To schedule a campaign to be delivered at your recipient’s local time, Instead of selecting a timezone, you’ll want to select a date and time and select the Recipient's Local Timezone option from the timezone dropdown menu. 

If you haven’t already, I would also suggest taking a look at the Deliver Message According to Recipients' Timezones  section of the Email Campaign Schedule and Send Options Help Center article which details this feature. 

I hope this helps!

David

Badge +2

Hi David, thank you so much for replying!

I’m aware that I have to select Recipient’s Time Zone instead of a specific time zone, I have succesfully scheduled campaigns like that in the past.

The issue is that right now I can’t see the option to select Recipient’s Time Zone, as below:

 

Is there a solution to this?

Userlevel 7
Badge +60

Hey @dani_bazzaal,

Would this campaign you’re scheduling happen to be an A/B test?

If so, then this would be an expected behavior where selecting the Recipient's Local Timezone as a scheduling option is not available. This is due to the testing phase required when running an A/B test. Scheduling campaigns to be received at a recipient’s local timezone is not supported when using the A/B test sending strategy. 

This is also mentioned in the Deliver Message According to Recipients' Timezones section of the article previous mentioned:

If you choose to send immediately, you cannot change the send time after you schedule the campaign. Also, note that you cannot send according to timezone if you're A/B testing the campaign.

David

Badge +2

Hi David,

I completely missed where it says you can’t send according to timezone if you’re A/B testing, thank you so much for pointing it out!

Thanks for your support :)

I dont have an A/B test, yet the option is not there. How can I send SMS based on timezones without A/B test? There’s no option for it like for email. See screenshot attached.

 

UPDATE:
Support confirmed there is a bug. The only fix currently is to clone the campaign and check if the function is there. Sometimes it even works!

 

Userlevel 7
Badge +60

Hey @saintBen,

Glad to hear cloning the campaign solved your issue! Are you still experiencing this odd behavior? 

Thanks for bringing this minor glitch to our attention as it should be resolved now,

David

Reply