Solved

SMS klaviyo disable automated text

  • 16 May 2023
  • 6 replies
  • 208 views

Badge

Hi!!

can someone please help me!

i turned off the double opt in on klaviyo for sms, but i think its still doing it to my  customers, i get the “you received a new sms from so and so’s number, and then it sends them the automated text that says send this to subscribe to reoccuring personalized marketing alerts from klaviyo library how can i disable this and then check to see if it worked cause they dont know what to send back, so they dont even subscribe lol HELP ME

icon

Best answer by David To 16 May 2023, 16:55

View original

6 replies

Userlevel 7
Badge +60

Hello @Abigailv,

Welcome to the Klaviyo Community!

Sounds like you may be experiencing a similar behavior as @redstickspice. I’ve included the Community post below that describes this:

As mentioned, this sort of behavior is often times caused by not fully setting up the source of where/how you’re collecting these SMS subscribers from. Particularly if you’re using a multi-step signup form or a click-to-text in an email. 

I hope this helps!

David

Badge

Ok so how do i fix it ? Is my question

 

Userlevel 1
Badge +3

Go to settings → SMS → Automations → and check under ‘keyword management’ - there should be a line item there that shows what is automatically sent when someone opts into your SMS program. If that isn’t it, scroll a little to ‘subscribe keywords’ or ‘subscribe links’ and see what your settings are there - you could also be using a subscribe link which does require you to have a keyword chosen for them to reply with, it’s not necessarily a double opt-in per se, but an extra step if you’re using that kind of link.
I’ve actually subscribed to many, many companies’ SMS messages and I’d say a good 15% have the default Klaviyo SMS language still in their auto-response 😆

Badge

Omg yeah, it’s kind of hard to figure out hahah but ok i think i fixed it how do i preview to see if it worked is their a preview test ?

Badge

Also how do i figure out or what steps do i need to take to not have my emails go to spam ?

Userlevel 7
Badge +60

Hi @Abigailv

 

Thanks @eMeg for hopping in to to share your knowledge with a peer, that’s what makes this Community great! 

 

If your emails are going to spam, that means you need to focus on improving your deliverability, which is essentially building your sender reputation with inboxes and proving them that you have no malicious intent and your subscribers actually want to open your emails! We have awesome resources I’ll link below, but essentially you can decrease your spam rates by the following, which his explored more in  our spam help center documentation here:

  • Make your unsubscribe link easily accessible
  • Enable double opt-in
  • Enable global unsubscribes
  • Avoid spammy subject lines
  • Ensure that your emails render for all users

 

Additionally, here are more helpful resources to gain more insight and get out of spam! 

 

Thanks for partipcating in the Community, hope this helps! 

-Taylor

Reply