Solved

Why did my Flow Not Send Users Through When I Back-populated in Draft Mode?

  • 16 March 2022
  • 5 replies
  • 118 views

Badge +1

Hi, 

I have recently attended Klaviyo Growth Webinar regarding the Sunset Flow and have created one following the instructions. 

 

The flow is tied to an unengaged segment populated with unsuppressed and unengaged accounts, and have been back populated (experimented with both back-populating options - giving each circa 24h to take effect), yet the entire original segment of 700+ accounts is skipped for some reason (Email cancelled) and it seems to be working only on accounts added AFTER it went live, regardless of the back populating selection. 

 

What am i doing wrong?

icon

Best answer by Taylor Tarpley 16 March 2022, 16:21

View original

5 replies

Userlevel 7
Badge +55

Hi @Mark W.

 

Welcome to the Community! Happy to help here!

 

To make sure I am following correctly here, do you mean to say that when you back populated your flow the first time, with the 700+ accounts, before the flow was turned live? 

 

Once I know this bit of info, I can more adequately asses the theory of what might be happening here!

 

Looking forward to working this out together in the Community!

-Taylor 

Badge +1

Hi @Taylor Tarpley - Thank you for your help :)

Yes, I back populated with the 700+ contacts before making it live, assumed once it goes live the contacts might update and start sending, which did not happen. 

 

I then went on draft mode, tried back populating again, this time choosing the second BP option, but it didn’t help either, all the segment contacts which were created before going live are still under Email Cancelled status. 

Userlevel 7
Badge +55

Hi @Mark W. 

 

 Thank you, that was the confirmation I was looking for!

 

According to our help center article on How to Back-populate a Flow, it confirms that a Flow will need to be in either Manual or Live mode when you back-populate for it to work successfully! I would ensure your flow is live and choose the option to populate relative to when you hit the back-populate button. When you schedule recipients based on when you back-populate, this treats recipients as if they just joined your list or segment. They’ll start at the very beginning of the flow and move through it one step at a time, like any other recipient. I’d recommend checking out our documentation on How Back-Populating Works in Klaviyo, a different article then the one I linked above, to learn more! 

 

Finally, I’d suggest checking out our Academy course on Automating the Customer Journey with Flows to become a Klaviyo Flow Pro! 

 

Thanks for participating in the Community!

-Taylor 

 

 

Badge +1

(UPDATED)

 

Thank you for your help @Taylor Tarpley 

 

The articles and the course are definitely the next step - thank you for the links!

 

I have activated the back-populate (relative to hitting the button) on a Live flow, it still shows the 700+ addresses as skipped. The adresses went to populate the next mail on the list and were pending delivery there, as the “Suppress  as True” property became active based on the previous skipping. 

I moved the flow to Draft mode, cloned it, repeated the actions as you have mentioned on the cloned flow, and it seems to be working correctly now :) 

Thank you!

Badge +1

 

 

Reply