Solved

How to set block styles?

  • 2 March 2022
  • 4 replies
  • 126 views

Userlevel 3
Badge +5
  • Problem Solver I
  • 35 replies

Hi There,

We’re new to Klaviyo and are having trouble understanding templates (new editor).

A limited number of styles can be saved but not for blocks. I guess we could style and save all blocks in the template, then duplicate them for an email but this isn’t useful if a previous change removed the block - right?

Wouldn’t it be better to save block styles into the template so that you never have to repeat design work?

Or are we missing something basic here!

Cheers, Ben

icon

Best answer by alex.hong 3 March 2022, 04:40

View original

4 replies

Userlevel 3
Badge +5

Have just discovered that some text blocks wont clone the content/settings when you duplicate them - is this normal or a bug maybe?

This issue kind of ruins the workaround where we style all the blocks in a template, then duplicate styled blocks as needed.

Also, is it just us or is the editor incredibly slow and sticky compared to Campaign Monitor’s editor? We’re using Chrome on a Mac. 

Cheers, Ben

Userlevel 7
Badge +58

Hi there @Ben,

Welcome to the Community! 

Have you tried to use the save feature and are you seeing that the blocks do not appear?

You would be able to save your blocks by hovering or clicking on a block and selecting the star icon. This will save the selected block. 

2019-09-20_11-44-19.png

I have provided an article for reference on creating and managing saved blocks

There can be a case where your browser or cookies(cache) could be holding onto a bad or delayed session, causing a hiccup. I recommend clearing out your browser cookies, logging back into Klaviyo, and testing the template again. 

But I would also suggest that updating your browser and computer, clearing the cache, restarting your browser and computer and doing an overload of these things may cause speed issues on the platform of your computer. Since Klaviyo is web based, any performance issues on our end would come from internet speeds or servers as opposed to the technology you are using.

 

Best,

Alex

Userlevel 3
Badge +5

Thanks Alex,

Sorry, I didn’t understand that the Star icon updates the default block for that template. Will review the link. Will also logout and clear cache to fix the odd behaviour we’re seeing.

Cheers, much appreciated.

Ben

Userlevel 7
Badge +58

Hi @Ben,

Feel free to followup with any issues you run into after experimenting.

 

Thank you!
Alex

Reply