Solved

How to translate unsubscribe and view in browser links in emails


Badge

Hello,

sorry for the question but so far I haven’t managed to find options to translate unsubscribe and view in browser anchor texts in campaigns’ emails. Also formatting (ie. color) doesn’t seem to work.

Cheers

icon

Best answer by Dov 20 April 2021, 15:28

View original

10 replies

Userlevel 6
Badge +5

Hello @Assistenza,

Thank you so much for sharing your question and reaching out to the Community to explore some solutions.

You can translate the unsubscribe text following this format: {% unsubscribe 'translated text here' %}

Likewise, you can translate the web view text using this format: {% web_view 'translated text here' %}

You can adjust the color of links throughout the email under the “Styles” tab.

 

Finally, our template editor uses a hierarchy of styles. If the link color does not change after adjusting it in the Styles tab, I recommend reading into my recommendation in my reply here.

Thanks and have a great day.

Badge

Ok, thanks clear now.

I understand now I need to change each single unsubscribe link in all flows’ emails, etc.. manually one by one, correct? If so, this is pretty sad..a general setting for commony used links/fields would be miuch better.

Cheers

 

Userlevel 6
Badge +5

Hi @Assistenza,

Thank you for your reply.

We currently do not have the ability to mass-update blocks for every flow email. However, we do have the ability to automatically inject the unsubscribe tag by clicking on “Insert Tag” within the Text Block, and you can customize it how you wish from there. Or you can stylize the unsubscribe tag and then save it as a block for reuse.  Then, drag and drop the updated block. 

2019-09-20_11-44-19.png

Badge

Thanks.

Saving a new block is definitely useful but now doesn’t make a big difference since I should anyways go through all flows’ emails and change blocks.

As a feature request please keep in mind a localization tab where users can use/translate labels.

Last, I have no “Insert tag” option in my editor...did I miss any advanced view switch or something alike?

Cheers

Userlevel 6
Badge +5

Hi @Assistenza,

Thanks for your reply.

The “insert tag” option is not available for all blocks. Are you using a text block? If so, and you still cannot see this option, can you show me a screenshot of what you’re seeing exactly? Please ensure to redact any sensitive information from the screenshot such as an email address.

 

Badge

Hello,

Yes I’m using a text block, see screenshot attached,

cheers

 

Userlevel 6
Badge +5

Hi @Assistenza,

It should be under “Carattere”. Can you verify if the tag populates when you select this option? It is the browser making this translation and so it may not directly translate as you’d expect.

Badge

Hello,

nope, “carattere”=Font and does that. “Dimensione”=font size and does that (checked already many times). I simply don’t have those options in editor….do you have them? I think interface has changed because while reading guides I saw those menus but not in my editor since I subscribed few weeks ago.

Anyways, not a big deal because I can find variables and dimension somewhere around forums and guide, localization is much more needed.

Cheers

M

Userlevel 6
Badge +5

Hi @Assistenza,

Thanks for that information.

I do have all of those options available in the editor. I would try saving the text block and re-adding it to see if “insert tag” becomes available. If not, I would also try hovering your mouse in the area the screenshots depicts below and try expanding the text block window to the right. It may be that the “insert tag” option is currently hidden. Also, I will submit your product feedback. Thank you!

 

 

Badge

Thank you Derin,

Can’t believe it...was hidden so expanding the editor to the right worked.

I used so many interfaces but could never think of it...please think of adding some icon to make users understand that part of the interface is expandable… :grin:

Cheers

Reply