Solved

Instagram feed not displaying


Badge
  • New Participant
  • 10 replies

I am trying to add an Instagram feed to an email as per the below link buyt it’s now working. Any ideas?

https://help.klaviyo.com/hc/en-us/articles/360004384031-Using-Instagram-Content-in-Campaign-Emails

icon

Best answer by Dov 13 July 2021, 22:42

Hi @mia & @Ciera,

Thank you for your replies.

@mia I noticed a colleague of mine was able to assist in the meantime and so I am summarizing his comments in this thread. @Ciera I hope this information is helpful for you as well.

First please ensure that your feed is valid. You can test this by previewing your feed from the “Data Feeds” tab.

You can also preview by clicking the Edit dropdown menu from the Data Feeds tab, and selecting Preview.

mceclip2.png

Also, keep in mind that the feed must be a valid XML format and which should be formatted like the following: https://rss.app/feeds/UNIQUE_FEED_ID.xml.

Per our documentation, you can also set up an Instagram web feed using their Basic Display API, or by using a third-party app. For example. you will find Yotpo’s guide to integrating with Klaviyo here. It explains how to set up the data feed here Displaying Review Highlights in Klaviyo.

Hope this was helpful!

View original

10 replies

Badge

I have no errors in my rss web fee preview 

Userlevel 6
Badge +4

Hello @mia,

Thanks for sharing your experience with the Klaviyo Community.

Are you able to provide anymore details in terms of your set-up? Are you able to preview the feed in the email template editor at all? If not, are you seeing any errors (if so please do share which error you are receiving)? Additionally, can you ensure you have clicked “data feeds” at the bottom of your email and checked the box to enable the feed?

Any other details you have would be helpful to help resolve the issue :)

Thanks and looking forward to hearing from you.

Badge

Sorry I though t I had already uploaded those. Here they are again.

 

Badge

Hi @dov.derin, any further insight? TIA Mia

@dov.derin I’m having a similar issue

Userlevel 6
Badge +4

Hi @mia & @Ciera,

Thank you for your replies.

@mia I noticed a colleague of mine was able to assist in the meantime and so I am summarizing his comments in this thread. @Ciera I hope this information is helpful for you as well.

First please ensure that your feed is valid. You can test this by previewing your feed from the “Data Feeds” tab.

You can also preview by clicking the Edit dropdown menu from the Data Feeds tab, and selecting Preview.

mceclip2.png

Also, keep in mind that the feed must be a valid XML format and which should be formatted like the following: https://rss.app/feeds/UNIQUE_FEED_ID.xml.

Per our documentation, you can also set up an Instagram web feed using their Basic Display API, or by using a third-party app. For example. you will find Yotpo’s guide to integrating with Klaviyo here. It explains how to set up the data feed here Displaying Review Highlights in Klaviyo.

Hope this was helpful!

Badge

@dov.derin thanks for that. Yes I did have a valid feed but changed to various feeds to see if that was correct. The resolution to this problem is that you can not preview in just Klaviyo you actually have to export to an outside email to see the results. Hope that helps others I. The future. 

Hello Dov,

I hope you can help me :)

I’m using rss.app for my instagram feed as mentioned in the guide and i copied the code from the guide also: https://help.klaviyo.com/hc/en-us/articles/360004384031-Using-Instagram-Content-in-Campaign-Emails. The feed works fine and I connected the feed in Klaviyo and it works but I have some problems with the code from the guide and the feed still. Therefore i have a few questions:

  1. It doesn’t load all of the posts from the feed. I contacted rss.app and the fault is not on their side unfortunately. So I hope you can help me understand why it it skips some posts / doesn’t view them. (Shown on the first screenshot)
  2. The code seems to mess up the positions of the elements in the rest of the mail. It’s like the css or styling of in the code effects everything in the mail which is weird. And it is only in some mail clients. It happens in outlook on both mobile and desktop but works in gmail and the preview. (Shown on the second screenshot - on the left is how it’s not suppose to be and the right how it is suppose to look like)

     I really really hope you can help us! We’re a bureau using Klaviyo for many of our clients, so it would really be a big help! I see some are succeding in adding an Instagram feed to their e-mails and it looks awesome! :)

Best regards

Christine

Userlevel 6
Badge +4

Hi @ChristineH,

Thank you for sharing this information with the Community.

First, I recommend quickly updating your data feed. You can do this by navigating to to Data Feeds tab > click on feed name > Update Feed.

Next, on your first question, can you confirm if you are viewing these Instagram images through a preview or if you noticed missing images in a live send? I ask because certain file formats don't end in the standard .jpeg, .png, or .gif because of the additional parameters added by Instagram which can cause issues with Klaviyo in-app previews. It may be that simply previews are impacting images being displayed rather than live sends.

Also, confirm that the image URLs you are using in your feed are formatted consistently and correctly for each URL. You can preview your feed through the Data Feeds tab to verify these image URLs. You can also check out our troubleshooting guide here. As an alternative, you can add static images of your Instagram to your messages. This is recommended if you are having trouble generating a feed on content directly from your Instagram account. For more information, check out our article on Using Images in Templates.

 

Additionally, if none of the above helps, I know Instagram was making updates to the way feed were pulled roughly a month ago. It may be worthwhile checking in again to see if they have any further information for you on that update that may have impacted your feed.

With respect to Outlook, Outlook sometimes skews HTML emails because all versions since Outlook 2007 use Microsoft Word to render HTML/CSS. Klaviyo is relatively limited in how we can remedy this because it is an Outlook-specific issue. For more information on this, I recommend reviewing the post below which speaks to this issue and a potential resolution

 

Hi @Dov ,

 

Thank you so much for your reply, I appreciate it :)

 

I previewed the mail to myself by sending an email but I did not send the mail to the maillist/customers. Would I have to set the mail as live in order to make sure?

 

I also updated the feed serveral times, checked the code for the missing posts and the image URLs. Everything looks fine.

 

Thank you, for you heads up on the change in Instagrams way of pulling the feed. I will keep my eye on that.

It makes sense that the Outlook skews the HTML, I did not know about that.. 

 

Thank you for your time and help, it clarified a lot for me . Have a nice weekend!

 

Best Regards

Christine

Reply