Question

Stripe webhook not working

  • 20 May 2021
  • 3 replies
  • 116 views

Badge

We’ve set up a transactional flow to send an e-mail for every successful payment in Stripe and we’ve set up the Stripe integration and webhook. We can see the webhook is syncing but we’re getting no data (test or otherwise) even thought we know that there have been payments made.

 

Would anyone be able to help? We’ve tested a number of diff end points and just aren’t getting any data through.


3 replies

Userlevel 6
Badge +4

Hello @TechGetter,

Thanks for sharing this experience with the Community!

Can you confirm if you’ve followed the instructions to integrate Klaviyo with Stripe through the How to Integrate with Stripe article? If so, can you also let us know if you any of the following Stripe events/metrics are being shared and synced to Klaviyo?

  • Failed Payment
  • Issued Invoice
  • Refund Payment
  • Successful Payment

In the event you have successfully integrated Klaviyo with Stripe but none of these events are being synced to Klaviyo, this may mean that there were no email address associated with these specific Stripe events. As stated in the I am not seeing all activity in Stripe sync to Klaviyo subsection of the Shopify Integration article:

 

Klaviyo uses an email address to uniquely identify a person. Because of this, Klaviyo can’t create a profile for someone who is not associated with an email address. Likewise, Klaviyo can’t link an event to a profile if it is not associated with an email address.

Keep in mind that first name/last name inputs are not necessarily consistent or unique, so we don’t create profiles based on this information alone. Doing so would lead to duplicates and inaccurate tracking.

 

I would recommend testing again but ensuring that the events you were pushing have an associated email address in order for Klaviyo to recognize these events to allow the associated flows to trigger.

Hope this helps!

David

Badge

Hey David - we’re not getting any events in spite of setting up according to the guide. We can see that all of the transactions have e-mails associated with them too.

Is this an issue you’ve seen before?

Thanks,

Rach

Userlevel 6
Badge +4

Hey @TechGetter,

Can you confirm if you’ve connected the correct Strip account with your Klaviyo account? 

I would suggest attempting to re-integrate Stripe with Klaviyo by following the below steps after clearing your cookies and cache to prevent any of these aspects from effecting the connection:

  1. Completely remove (Not Disable) the Stripe integration within Klaviyo
  2. Log out of Klaviyo
  3. Clear the cookies and cache on your browser
  4. Fully close the browser
  5. (Optional) Restart your computer 
  6. Relaunch an Incognito or Private Browser
  7. Log back into Klaviyo 
  8. Re-Integrate Stripe with Klaviyo again via the Integration’s tab by following the How to Integrate with Stripe instructions

I would also ensure that when setting up the webhooks as part of the Stripe integration to include all of the charge and invoice events. You can find a list of the required endpoints within the Stripe Integration article provided earlier and below:

David

Reply