Solved

There was an unknown issue trying to connect. - Woocommerce Integration

  • 21 May 2021
  • 3 replies
  • 66 views

Badge

Having issues integrating with Woocommerce, getting the error 

 

There was an unknown issue trying to connect.

 

I’m certain the Store URL, the Consumer Key and Secret are correct, also the public API connected to the plugin is correct. 

 

All plugins , Woocommerce and Klaviyo is up to date.

 

Legacy API wouldn’t connect either

 

Any idea?

icon

Best answer by Dov 21 May 2021, 21:47

Hello @Jaq ALL,

Thank you for sharing your question with the Klaviyo Community.

I recommend double-checking that you’ve completed every step in our WooCommerce integration doc including enabling read/write permissions.

 

If you can confirm this is the case, I recommend completely removing the WooCommerce integration and re-integrating once again using that guide.

If those options are tested and are still not providing a solution, it may be a more detailed, account specific issue that requires more investigation. If this is the case, please follow up after you have tried the above suggestions. Of course, also open to hearing if other Community members have any thoughts.

Thanks and have a great weekend.

 

View original

3 replies

Userlevel 5
Badge +4

Hello @Jaq ALL,

Thank you for sharing your question with the Klaviyo Community.

I recommend double-checking that you’ve completed every step in our WooCommerce integration doc including enabling read/write permissions.

 

If you can confirm this is the case, I recommend completely removing the WooCommerce integration and re-integrating once again using that guide.

If those options are tested and are still not providing a solution, it may be a more detailed, account specific issue that requires more investigation. If this is the case, please follow up after you have tried the above suggestions. Of course, also open to hearing if other Community members have any thoughts.

Thanks and have a great weekend.

 

Userlevel 5
Badge +2

@Jaq ALL On one occasion I've had an issue where there was an active firewall on the hosting side that was blocking incoming connections to Woocommerce. Not sure if it's the case but worthwhile checking to be sure.

 

Userlevel 5
Badge +4

Thank you @Omar for pointing out the firewall as a possibility as well!

@Jaq ALL On one occasion I've had an issue where there was an active firewall on the hosting side that was blocking incoming connections to Woocommerce. Not sure if it's the case but worthwhile checking to be sure.

 

@Jaq ALL, please do let us know if you are still having trouble after reviewing the above suggestions.

Reply